Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After Reboot no Windows Partition is found and installation cannot start. How can we solve this, in order to try Ubuntu ?

It says I only have free space available, but that isn't true. I'm on the demo now.

If I try to install from the demo, I do get:

"The following partitions cannot be unmounted /isodevice"
share|improve this question
    
No luck. I noticed that sd1 was my start disk part available on ubuntu instalation and NOT sda0. Somehow I have a hidden sda0 that I cannot fix or remove neither with gparted. It must be the recover HP partition. I've installed Ubuntu using all this space available, backup some windows documents, and starting on sda1. I will never look back. ;) –  MEM Aug 20 '10 at 8:50

2 Answers 2

up vote 3 down vote accepted

I believe there is a know bug with wubi and windows vista.

Here is a forum link that might help

share|improve this answer
    
Thanks. So if I use a live cd version, and I try to installed, without losing my vista installation, probably it will recognize that something exists ? –  MEM Aug 18 '10 at 21:28
    
No luck. Even with the installation startup cd, I'm unable to see the vista 64 partition. :( –  MEM Aug 18 '10 at 22:57
    
@MEM Look to see if you can restore MBR ( Master boot Record) –  myusuf3 Aug 18 '10 at 23:27
    
Thanks - I've tried to repair MBR by using Vista 64 recovery cd, I issue the command, for both, MBR and Boot. Both commands were successful, but the partition still doesn't appear on Ubuntu Installation process. Well.. I will: 1) Make backup of stuff here. 2) use a partition tool on boot and clear absolutely all 3) Install Ubuntu and never look back! Drastic still. :s Thanks a lot for your replies garbagecollector. –  MEM Aug 19 '10 at 0:23
    
@mem no problem its what we are here for. I recommend not installing through wubi ever. :) –  myusuf3 Aug 19 '10 at 1:06

You seem to have damaged or altered your partition table, wubi doesn't manipulate it so it sounds strange that it should be the cause of this. You could use a tool like PhotoRec to recover files you didn't backup.

Another tool called TestDisk might even be able to recover your partition but if you installed filled over its position, it is likely to be damaged beyond a meaningful reparation.

Lastly if you have a wubi installation (and it is working) then you can access your Windows partition from the /host/ folder.

share|improve this answer
1  
Thanks a lot, I end up forget about that partition at all. And I'm a happy solo linux user. :D Yeah! ;) –  MEM Sep 14 '10 at 7:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.