Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to figure out why port 22 will never let me ssh into my laptop. Here's what I'm trying:

ryan@gigantic-laptop:~$ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere
22                         ALLOW       Anywhere (v6)

22                         ALLOW OUT   Anywhere
22                         ALLOW OUT   Anywhere (v6)

ryan@gigantic-laptop:~$ ssh localhost
ssh: connect to host localhost port 22: Connection refused

Or if I try to disable:

ryan@gigantic-laptop:~$ sudo ufw disable
Firewall stopped and disabled on system startup
ryan@gigantic-laptop:~$ sudo ufw status
Status: inactive
ryan@gigantic-laptop:~$ ssh localhost
ssh: connect to host localhost port 22: Connection refused
ryan@gigantic-laptop:~$ ssh 127.0.0.1
ssh: connect to host 127.0.0.1 port 22: Connection refused
ryan@gigantic-laptop:~$ sudo nmap 127.0.0.1

Starting Nmap 6.00 ( http://nmap.org ) at 2013-02-23 18:14 PST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.000016s latency).
Not shown: 999 closed ports
PORT    STATE SERVICE
631/tcp open  ipp

Nmap done: 1 IP address (1 host up) scanned in 0.09 seconds

What am I doing wrong?

share|improve this question

1 Answer 1

I need to install sudo apt-get install openssh-server.

share|improve this answer
    
I have open-sshserver and still can't get port 22 open. –  dibs Apr 23 '13 at 1:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.