Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some strange reason, installing and updating anything becomes a lot slower than before when i was on 10.04.

From this thread about checking hard drive speeds:

An HDParm test shows that the read speed is pretty good

:: sudo hdparm -Tt /dev/sdb1

/dev/sdb1:
 Timing cached reads:   23586 MB in  2.00 seconds = 11809.52 MB/sec
 Timing buffered disk reads: 342 MB in  3.01 seconds = 113.74 MB/sec

But when I do dd,

 :: dd if=/dev/zero of=/tmp/output bs=8k count=10k; rm -f /tmp/output
^C8600+0 records in
8600+0 records out
70451200 bytes (70 MB) copied, 48.5711 s, 1.5 MB/s

(I had to ctrl+c because it was taking too long)

And I also tried to copy an 83mb file locally

:: gcp xco xco2 
Copying 83.51 MiB 100% |#############################|   1.31 M/s Time: 00:01:06

As you can see, very slow read (or probably write time), but when I tried to copy stuff from the disk to tmpfs, it's also as slow as above.

What's the probable cause of this issue?

share|improve this question
    
Is this a possible duplicate of: askubuntu.com/questions/122512/… –  Mordoc Feb 24 '13 at 3:02
    
Actually, I just found the answer.. really strange but only having a single ram stick restored the speed to original values, but it shouldn't affect anything, making me think it's a kernel bug :( –  kamziro Feb 24 '13 at 3:18
    
Could it then be mismatched ram? –  Mordoc Feb 27 '13 at 2:56
    
Could be, but the ram continued being fast, while the hard drive was the one being slow. Could be the motherboard, could be the ram, it's really gonna take a while, this one. –  kamziro Feb 27 '13 at 3:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.