Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been trying to dual boot OS X and Ubuntu on my MacBook Pro 7,1 and have found a few issues. First of all, I am using this guide. I have just installed Ubuntu and rebooted. I saw GRUB instead of rEFIt. When selecting Ubuntu and logging in, I get graphical glitches.

The glitches vary, and sometimes I get one before I hit the login screen.

When I try to boot OS X I get this:

However, I can get a terminal working nice!

So, my questions are: how do I get Ubuntu to work without graphic issues and how can I get OS X to boot again and preferably use rEFIt as the guide intended to boot the 2?

Quick Update: I have successfully booted OS X 10.8! I held option when starting, selected my OS X hard drive and from there it started rEFIt. I selected OS X and it booted as normal! Now I just need Ubuntu to work correctly.

Update 2: rEFIt now appears on startup, and the only issues is the Ubuntu graphics. If I can get unity to start correctly, and all the graphics to be displayed nicely, I'll be good. Yay, progress!

Update 3: In the process of reinstalling Ubuntu.

share|improve this question
Could you provide more information in your question? E.g., what happens after you push the power button? Do you go into GRUB? Is there an entry for OS X in Grub? – kalaracey Feb 24 '13 at 1:26
Yes and yes it does. – ryebread761 Feb 24 '13 at 1:32
Ok so there is an OSX entry. Have you tried selecting the OS X entry instead of the Ubuntu/Linux entry (using the arrow keys)? What happens then? – kalaracey Feb 24 '13 at 1:33
Here is what the glitch has looked like before, but as I said, it varies.… – ryebread761 Feb 24 '13 at 1:51

Ok so there is an OSX entry. Have you tried selecting the OS X entry instead of the Ubuntu/Linux entry (using the arrow keys)? What happens then? UPDATE: Yes you have, but you get an error, you have updated that in your question

Update 1

Ok so from your updates it looks like you've made some progress; I'm relieved that you didn't wipe out your OS X partition! Also, putting rEFIt on is great as well. Could you specify (a) what MacBook Pro model you have (something like 6,2 or Mid 2010 which can be found by going to the upper left hand corner, clicking the Apple, click About This Mac >> More Info, and there it will say something like "Mid 2010') and (b) what version of Ubuntu?

If you can't solve your graphics problem (I would try googling it), then best bet would be to reinstall Ubuntu. I can help with specific install instructions for Mac, if you want. I've done this quite a few times. One thing - the Graphics problem might be because of what model your Mac is / if you installed it with EFI or BIOS support. Did you use the normal Ubuntu install disk, or the special Macintosh one?

I always use the Non-Mac version. The Normal version. I would advise that you do as well. It appears on the Ubuntu Apple hardware page ( that your 7,1 is supported quite well under 12.10. I would wipe out Ubuntu and then reinstall it and see how it goes.

Update 2

You say:

I've run into a couple roadblocks. 1. I went into disk utility and attempted to remove both the main Ubuntu partition and its swap. The swap refuses to be removed. 2. I somehow removed my Recovery Partition, is there any way to get this back? 3. Is there something else I should do to uninstall? rEFIt still has Ubuntu as an option (this may go away once I get rid of the swap)


  1. I don't know why Disk Utility won't remove the swap partition. Just to clarify, you open Disk Utility, select your hard drive in the left-hand pane, then click on the "Partition" Tab, then select the Swap partition (whatever you named it) in the little graphic / table describing all your partitions on that drive (NOT in the left hand pane) under the title "Partition Layout" and click the small "-" button below the graphic / table and follow the prompts? Please give the error you receive if this doesn't work.

  2. I, too, have accidentally removed my recovery partition. Bummer. The only (safe) way to recreate the partition (or any way that I trust; you can Google the problem, but some of the ways online with custom scripts from other people seem a little sketchy) is to reinstall Mac OS X. This is actually not as bad as you think; you need to re-download your version of OS X (I assume Lion or Mountain Lion) from the Mac App Store, rerun the install. All your files and configs will be the same. Make sure you wipe out all the partitions after your main Mac one, though, first (including swap).

Then your recovery partition will be back where it started. Then you can reinstall Ubuntu. Also, when installing, at least when I installed Ubuntu 12.04 on my Mac, I did not use a swap partition. Typically 4GB is enough (default on Macs, maybe you have 8?) You can later create a Swap file which acts like swap but is just a file on disk in Ubuntu. I'm adding an Answer with all the info in the comments, which I'll update as your problem progresses. Having no Swap removes some added complexity to everything.

share|improve this answer
Disk utility just makes it look like it is taking it away but doesn't actually do so. I get no error message. The partition is grayed out, if that helps. – ryebread761 Feb 27 '13 at 22:19
There, I got rid of it by erasing it to a FAT partition and then deleting that. So now I reinstall OS X (without erasing settings)? – ryebread761 Feb 27 '13 at 22:25
Ok so your partition layout should be just Mac OS X, with a bunch of freespace after it (however much you want to allocate for the Recovery Partition (which is pretty small) and Ubuntu). What version of OS X do you have installed? I had 10.8 Mountain Lion, and downloading OS X 10.8 Mountain Lion from the Mac App Store, and installing it left everything the same. – kalaracey Feb 28 '13 at 0:16
Just one thing: before doing anything like this, you should back up your computer with Time Machine. There is no excuse not too. Also, on a lighter note, here are two resources that I used to learn that you can just reinstall OS X with no harm to your installed apps / docs / configs, but recreate the recovery disk:… and… – kalaracey Feb 28 '13 at 0:20
As far as partitions go, I extended OS X to take the full disk, bad idea? – ryebread761 Feb 28 '13 at 1:42

Your grub configuration is wrong, I actualy just fixed this on my macbook pro. In grub configureation, /boot/grub/grub.cfg, delete the menu entries for "Mac OS X (64-bit) and (64-bit) but copy your uuid (where it says search --no-floppy --fs-uuid --set=root youruuidhere) and just put this:

menuentry "Mac OS X (32-bit)" --class osx --class darwin --class os {
    insmod part_gpt
    insmod hfsplus
    set root='(hd0,gpt3)'
    search --no-floppy --fs-uuid --set=root youruuidhere
    chainloader /usr/standalone/i386/boot.efi
menuentry "Mac OS X (64-bit)" --class osx --class darwin --class os {
    insmod part_gpt
    insmod hfsplus
    set root='(hd0,gpt3)'
    search --no-floppy --fs-uuid --set=root youruuidhere
    chainloader /System/Library/CoreServices/boot.efi

This method just dumps the grub bootloader into the efi component of the mac operating system instead of trying to load the xnu kernel manually with the kernel extentions. Grubs way of booting mac has never worked for me so i just use apples way of booting. Hope this works for you too.

P.S. This method i probably not the best because grub constantly reconfigures itself, instead of editing /boot/grub/grub.cfg it might be better to edit a grub config file such as the one that produces these entries, /etc/grub.d/30_os-prober or change grubs custom.cfg to add these and disable os_prober

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.