Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't seem to install Ubuntu 12.10-desktop-amd64 to my computer. I've written the install to my memory stick but it flashed secure boot error really fast then sits on the grub screen.

share|improve this question

I found the problem. There was no mention anywhere of having to use a special image called amd64+mac anywhere. Everything worked after I used one of these images.

share|improve this answer

Ubuntu 12.10 is supposed to include Secure Boot support; but maybe there's a bug that's affecting you, or maybe your computer tried to boot the disk in BIOS/legacy mode rather than in EFI mode (which is required for Secure Boot).

Probably the easiest way to proceed is to disable Secure Boot. This is a firmware option, but unfortunately, there's no standardization of firmware user interfaces, so I can't provide step-by-step instructions on how to do this. You'll just have to activate your firmware setup utility (usually by pressing Del or a function key early in the boot process) and browse the options until you find one related to Secure Boot.

Once you've done this and booted the Ubuntu installer, drop to a shell and check for the presence of a directory called /sys/firmware/efi. If it's present, proceed with the installation. If it's not present, you've probably booted in BIOS mode. Although you could install in this way, that will create complications related to selecting which OS to boot, so I recommend you reboot and try checking your computer's boot menu (usually accessed by pressing a function key early in the boot process) to find a way to force an EFI-mode boot of the Ubuntu installer.

share|improve this answer

I have the same notebook and the same problem. When I tried to boot using different ubuntu live versions it hangs up in the grub menu (totally freeze) most of the times. But the menus respond with other distros or at least it can boot (with debian 6 and 7 full use of boot menu and boots with fedora 17) And one thing that i'm not able to figure, but happens, is that if a boot with debian live cd, not install anything, just boot, and then reboot with a ubunutu live cd (12 or 13) the grub menu doesn't freeze most of the times. Its odd.

It's not too elegant, but you can give a try to this, and try ubuntu 13, that seems to be more compatible with this lenovo model (z475)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.