Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just moved from Windows to Ubuntu. Before I uninstalled windows I put some documents that I needed on a CD. Once I had installed Ubuntu I put the CD in to get the files back. But all I get is the message...

Error mounting /dev/sr0 at /media/chris/UDF Volume: Command-line `mount -t "udf" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,umask=0077" "/dev/sr0" "/media/chris/UDF Volume"' exited with non-zero exit status 32: mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

People are not going to migrate from windows if Ubuntu can't even do a simple task like open a CD without this meaningless error message.

share|improve this question
1  
Well as the error suggests, sometimes usefull info is found in the syslog. Can you open a terminal and post the output of: dmesg | tail here? – MrHug Feb 23 '13 at 17:56

try to make /media folder writable by

sudo chmod 777 /media 
share|improve this answer

Here is something you can try:

code:

gksu gedit /etc/fstab

then add this code after the last line in fstab

code:

/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
share|improve this answer
    
tried but I get another error Error mounting: mount exited with exit code 1: helper failed with: mount: mount point /media/cdrom0 does not exist – mojo706 Jul 30 '13 at 12:19
    
/dev/sr0 /media/cdrom udf,iso9660 user,noauto,exec,utf8 0 0 – dr_smit Jan 23 at 13:54

/dev/sr0 /media/cdrom udf,iso9660 user,noauto,exec,utf8 0 0

worked like magic as I had already existing /media/cdrom created by sudo mkdir /media/cdrom

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.