Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 10.10 on a computer that was previously running 10.04 (that worked fine).

Now, each time I boot up, it starts up in a command line login prompt. I can login and it stays at the command line (as expected). I can then manually start gdm with sudo start gdm and it works fine. I can also enable compiz (using proprietary nvidia drivers) so I'm reasonably confident that it's not a driver problem (at least not in the sense that the drivers just flat out aren't working).

Interestingly, if I leave it at the command prompt without logging in, after about 5 or 10 minutes, gnome starts up on its own. I'm not sure what is causing this.

This is what dmesg | tail gives me after a manual start of gdm:

[   15.664166] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  270.18  Tue Jan 18 21:46:26 PST 2011
[   15.991304] type=1400 audit(1297543976.953:11): apparmor="STATUS" operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" pid=990 comm="apparmor_parser"
[   16.606986] eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
[   18.798506] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   26.740010] eth0: no IPv6 routers present
[   90.444593] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[  189.252208] audit_printk_skb: 21 callbacks suppressed
[  189.252213] type=1400 audit(1297544150.218:19): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=1876 comm="apparmor_parser"
[  189.252584] type=1400 audit(1297544150.218:20): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=1876 comm="apparmor_parser"
[  351.159585] lo: Disabled Privacy Extensions
share|improve this question
    
Have you tried Ctrl + Alt + F7 or Ctrl + Alt + F8? –  Lekensteyn Feb 12 '11 at 21:19
    
Hmm sounds like an init daemon (upstart) bug. Try command initctl status gdm before gdm starts. –  LGB Feb 12 '11 at 21:25
    
initctl status gdm outputs something like "gdm stop/waiting" –  greggory.hz Feb 12 '11 at 21:47
    
ctrl+alt+f7/8 just brings up a black screen. –  greggory.hz Feb 12 '11 at 21:48
add comment

4 Answers 4

How about purging gdm and reinstalling it so it rewrites the init scripts?

share|improve this answer
add comment

Probably what I'm going to suggest look foolish but may resolve it.

Check the default init level if it's set to 3 and try as xorg.conf file as 'AJB' suggested.

(or)

Boot the system from LIVE CD and manually run fsck as fsck -y /dev/sda1 and reboot the system. Taking backup before running fsck is also recommended.

share|improve this answer
add comment

Its a problem with NVDIA graphics card. To get the GUI , delete the /etx/X11/xorg.conf (move it to xorg.conf.backup) and startx

This should get you out of the command mode.

share|improve this answer
    
I did this, and the first time i ran startx, the display was really screwed up and it didn't use the nvidia driver. so i dropped back to the shell and ran nvidia-xconfig and did startx again which brought me back to my normal x session. however, a restart showed that the problem still persists. it just boots to the command line login prompt. –  greggory.hz Feb 19 '11 at 23:47
    
Try login using the failsafe mode. It will work using the default graphics.Usually the display should be fine. Once you do that, copy the /etc/X11/xorg.conf.failsafe to /etc/X11/xorg.conf –  AIB Feb 23 '11 at 15:19
add comment
up vote 0 down vote accepted

Fixed when I upgraded to 11.04

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.