Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo u410 ultrabook. It's sata scheme consists of a 30gb SSD and a 1tb hdd in a raid0 with intel rapid start technology. I removed IRST and disabled the raid0. I want to install ubuntu on the ssd and /home on the 1gb hdd. I foolishly erased the efi partition on the 1tb and attempted to recreate it by formatting the ssd and creating a new GPT partition table. I made a 250mb fat32 partition (/dev/sda1) and filled the rest ~24gb with an ext4 partition (/dev/sda2)

I made a live USB using a 12.04.2 iso and universal usb installer. The installation completes fine however at the end I get an error "Failed to install grub-efi to /target/ the system will not boot" I tried to open terminal and update grub however it's not there and when trying to install grub-efi from the repo I get flagged for missing a lot of dependencies. Ubiquity crashes after the error message.

I had success a few months ago installed 12.10 using my friends usb cd drive however I broke the system and cant be down until I next see him. Is there a huge difference in 12.10 and LTS that would stop this install from working smoothly?

My net goal is to have Ubuntu running on the machine with steam (tf2 and bastion) and eclipse IDE. If 12.10 is better suited, and can solve this efi issue then I'll gladly install that however from my understanding LTS would be more stable and still run the modern updates of Quantal.

tl;dr Will 12.10 install grub-efi flawlessly? and if not how can I install grub-efi from the live usb onto a solid state drive /dev/sda with efi boot on /dev/sda1, ext4 mounted as root on /dev/sda2, and /home on the hard disk /dev/sdb2?

Conclusion: LTS wasn't capable of handling the uefi environment. Downloading and installing 12.10 worked flawlessly. Raring worked fine too, however it was unstable with the drivers necessary for steam.

share|improve this question
    
You can solve it choosing on boot screen the device option that doesn't use UEFI. –  user266005 Apr 6 at 18:21

4 Answers 4

up vote 3 down vote accepted

Ubuntu's been making slow but steady improvements in its EFI support for the last several versions, so yes, there are differences between 12.04 and 12.10 that could be important. That said, the fact that you got a bunch of dependency errors when you tried to install grub-efi suggests that a more fundamental problem might be the root cause -- perhaps there was a network problem that prevented a string of other packages from installing, for instance. If so, trying again at a later time might correct matters.

That said, on an EFI system, IMHO it's better to use 12.10 than 12.04. This is especially true if it's a recent computer that shipped with Windows 8, since such computers also invariably use Secure Boot, which Ubuntu 12.10 supports but Ubuntu 12.04 doesn't. This isn't the root cause of your problem, though, since 12.04's installation disc won't boot at all if Secure Boot is active; I mention it only for the benefit of others who might read this page.

share|improve this answer
    
My computer shipped with Windows 7, and has a 15$ upgrade to 8. My computer is ivy bridge, does that help center the cause? There is an option in the bios pertaining to uefi however when I disable it I see 'secure boot disabled' and I get a grey broken looking grub menu on the live usb and it fails to boot. If I enable it, I get grub EFI and the live session works fine. I'll download 12.10 after work and try again with that then and see if theres a difference. Is there an askbubuntu equivalent to bumping or will you be available when I chime back in? –  mikeymop Feb 23 '13 at 19:50

This error was solved for me by making sure there was an internet connection available to the installer.

When I chose not to connect I got this error.

share|improve this answer
    
Weird; me too. I had this error and just tried again with Internet connected and it worked. –  Tom Willwerth Jan 5 at 22:16
    
Worked for me too after connecting... –  Mohit Jain Jul 28 at 18:14

Try to disable BIOS QuickBoot/FastBoot and Intel Smart Response Technology (SRT).
Then install Ubuntu 12.10 <- IMPORTANT 12.10
Then try to install, if nedeed, grub-efi-amd64-signed

Regards,

share|improve this answer
    
I had already disabled Intel SRT. Quickboot isn't an option in the notebooks BIOS. I have to use 12.10 to install, if I try to install raring is fails so I usually just install 12.10 and then dist-upgrade to raring. Once on a kernel 3.8 or newer everything gets a little more stable. –  mikeymop Aug 12 '13 at 4:05

You should have

/boot/efi    

and about 100MB ,then everything is ok...

mine is

sda1 /boot/efi  100MB
sda2 /          100G
sda3 /swap      16384MB    
sdb1 /home      3TB
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.