Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Any better title is welcome. All of a sudden when I press:

  • d - I either see d typed in or I get a print screen window
  • e - I either see e typed or I see volume bar rise
  • c - I either see c typed or I have many different effects (depends on context)

So far I'm unable to tell what is the "trigger" or "toggle" for this peculiarity.

I'm frankly at a loss what to investigate. Few findings: - while this first manifested in a browser (FF + Vimperator) this is NOT browser limited - GVim, terminal even tty (I switched to it) can have that - In tty d becomes \; and c becomes ^[[5~b and presses Enter. - in kern.log I see no entries when tailing when I press d even when I see volume bar increasing upon keypress - I see no strange shortcuts when I open Keyboard Shortcuts window

Any clues? I had not run any updates recently, nor have I installed something. This interrupts my work to the point I had to borrow someone else's laptop to type this.

UPDATE

Visa1:

  • 3 - deletes first character in line and puts cursor there
  • # - inserts last cut or highlighted (I'm unsure here) thing

These have been tested only in terminal and tty and login shell.

Another keyboard - currently none at hand that I can plug in.

@Mordoc FN key inputs:

I don't think it's jammed key. Fn key works as expected except for volume. Pressing Fn+e doesn't give me e, though I had few times earlier, before posting this question where I had "toggled" this with function key. This however is not consistent.

Normal volume keys were on F2 and F3 and they do not work now. Mute key works as usual. So, it rather isn't the case for jammed key but it still found us something new.

2nd UPDATE

Problem "solved" itself equally suddenly as it had manifested.** Leaving this open for a week or so. Vasa1 - your comments were closest to the cause I think, so feel free to post them as an answer, along with "another keyboard" suggestion.

3rd UPDATE - root cause identified, problem solved

After a year the problem reappeared and what I noticed further is:

  1. it appeared more often when laptop was in unbalanced position
  2. it often disappeared when I pressed region next to touchpad

Took the laptop to the service and voila - keyboard was faulty. On new keyboard problem does not occur. Vasa1, right on the money.

share|improve this question
1  
What about # and 3? And have you tried another keyboard? –  user25656 Feb 23 '13 at 15:33
1  
I would be curious if a fn key press would do the same actions. For example on my laptop some of those keys are mapped to functions while holding down the fn key. Could it be that a key is stuck like the fn or ctrl key? –  Mordoc Feb 23 '13 at 15:38
    
@vasa1 you have some hidden knowledge it seems! # and 3 also have hidden behaviour -will update the question with results! –  LIttle Ancient Forest Kami Feb 23 '13 at 16:35
    
No special powers ;) It's just that c, d,e, 3 and maybe F2 get affected because they're in the same diagonal line. A friend had a dodgy keyboard with something similar. –  user25656 Feb 23 '13 at 16:43
1  
I think you should try to eliminate the possibility that it's a faulty keyboard. –  user25656 Feb 24 '13 at 15:16
show 4 more comments

closed as off topic by vasa1, raaz, Chris Wilson, Stephen Myall, hhlp Feb 26 '13 at 15:48

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.