Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the error which is showing down when I try to run the OpenGL programme.

I use 12.04 and my graphics is Intel® 965GM x86/MMX/SSE2

Vendor: Tungsten Graphics, Inc

Renderer: Mesa DRI Intel(R) 965GM x86/MMX/SSE2

Version: 2.1 Mesa 8.0.4

GLSL: 1.20

[From lab1-1.vert:]

0:1(10): error: GLSL 1.50 is not supported.Supported versions are: 1.00 ES, 1.10, and 1.20

[From lab1-1.frag:]

0:1(10): error: GLSL 1.50 is not supported.Supported versions are: 1.00 ES, 1.10, and 1.20

[From lab1-1.vert+lab1-1.frag:]

error: linking with uncompiled shadererror: linking with uncompiled shader

GL error 0x502 detected in init shader

GL error 0x502 detected in init arrays

My .vert and .frag has a #version 1.50 But even If I change them into #1.20 it is not working

Does any one know how to fix the problem ?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.