Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Problem

Frequently I get online without being asked to input a password, and then, after several minutes of having a connection, the connection stops and I am prompted for a password for the network. However, the username field and the connect button are greyed out, like in the picture.

Greyed out authentication screen.

This is... thoroughly irritating, to say the least. How can I fix it? (Google and the search bar have failed me so far.)

Details

  • If I close the pop-up, it will reappear in a couple minutes.
  • Occasionally rebooting the computer will allow me to get back on the network.
  • I'm running Ubuntu 12.04.2 LTS.
  • The networks seem fine; my old mac laptop has no troubles connecting to the same networks in the same locations.
  • This doesn't happen consistently.
share|improve this question
    
Is there any more information I can give to help figure this out? –  Matthew Adams Mar 1 '13 at 17:24
    
What is the model of your wireless router? Can you show all the the configuration that you can? You can upload the output in paste.ubuntu.com and then link it here. –  Lucio Mar 3 '13 at 17:29
    
@Lucio Unfortunately I don't know anything about the configuration of the router since it is my school's network. I can try and ask someone who works on it though. How might the router impact the fact that the message fields are ghosted out? –  Matthew Adams Mar 3 '13 at 20:27
    
Yes, tell to the network administrator about your situation and he should know where is the problem. –  Lucio Mar 4 '13 at 1:22
    
@Lucio Why would it have to do with the network though if my mac and other peoples' windows computers connect without any problems? –  Matthew Adams Mar 4 '13 at 1:40
show 2 more comments

3 Answers

Have you tried removing the saved connection? Click the network icon in the top right, click "edit connections", go to the wireless tab, click your connection in the list on the left and click delete.

Then disable/enable networking. That should clear any saved authentication info and allow you to put in a new username.

I'd compare the security settings with those on a machine that connects normally as well.

share|improve this answer
    
Thanks, but everything seems to be in order there. –  Matthew Adams Mar 5 '13 at 19:41
add comment

One thing you can look into are the certificates and authentication you're using. I checked Eduroam info of your university and it has info on Linux but it wants you to go through XpressConnect. It was like that at my old uni, too, but only for Windows and Mac (I believe) You can try this guide (steps 4 and 5 in particular) which lists out the steps for Linux. I think Eduroam is supposed to be worldwide so I would assume settings are the same everywhere.

EDIT: My current university's guide doesn't have the same steps as the other so perhaps they are not universal settings. Still worth a try though I think.

If all else fails, you could disable and re-enable networking or wireless instead of rebooting your computer. It's not going to fix anything but it's somewhat faster (if it even works).

share|improve this answer
    
Thanks for the advice- I'll try the guide out. (I'm actually at Carleton College.) Interestingly, disabling/re-enabling wireless has never got me back online, even though rebooting the computer does. –  Matthew Adams Mar 4 '13 at 21:44
    
sorry! i saw the email address and took the first hit on google... rookie mistake. i've updated the link and answer to make up for it. let me know how it works out! –  duxk.gh Mar 4 '13 at 22:38
add comment

I have the same problem. I'm on my local network at home. Sometimes the connection is just lost and then it asks for the password. I also experienced that if I leave the laptop for a couple hours and this happens then the windows start popping up continuously, even though I didn't press cancel or anything because I wasn't even close to the computer.

share|improve this answer
2  
Welcome to AskUbuntu! It looks like the information in your response regarding the situations in which you experience the issue would be better left as a comment to the original question; see askubuntu.com/faq#deletion for details. –  Jarmo Mar 4 '13 at 20:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.