Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

My laptop is the Acer Timeline Ultra M5-481TG. It has an Nvidia Geforce GT 640M LE gpu. I am running Ubuntu Studio 12.10.

I have tried to install this driver many ways because Nouveau eats my battery and I believe is somewhat out of date. I have even tried using sudo stop lightdm in another console. I have tried nvidia-current, nvidia-current-updates, nvidia-experimental-310, and the .run file of their website. Every time I open nvidia-settings it tells me to run the nvidia-xconfig' as root then restart X. I tried this both in X and with X stopped in an alternate console. I have also installed bumblebee and that did nothing to get the Nvidia X Driver running. I installed jockey-common as well and enabled these drivers using it, but again to no avail. When I run nvidia-xconfig it does create the necessary changes to the config file, but these don't result in it actually running or resolving the error. I have read very many articles and tried so many things. i.e. sudo apt-add-repository ppa:xorg-edgers/ppa and of course apt-get update, apt-get upgrade, and apt-get dist-upgrade. I have purged and reinstalled everything in numerous ways looking for just the right combination, no luck thus far.

This has eaten hours of my time! Please help and thanks!


sudo apt-get remove nvidia-common nvidia-current nvidia-settings && sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade && sudo apt-get install nvidia-common nvidia-current nvidia-settings && sudo jockey-text -e kmod:nvidia_current && sudo nvidia-xconfig && sudo restart lightdm

I made a "meta"-command for lulz and to give it one last shot. Still no luck.

share|improve this question
On another forum someone told me this: "Remove any proprietary nvidia driver you tried to install and then:"; – fowlslegs Feb 23 '13 at 17:55
I tried it without success and replied: "I removed nvidia-current, nvidia-common, and nvidia-settings with the synaptic package manager then followed the bumblebee instructions step by step. These instructions ended up asking me to reinstall so I did at the appropriate time. After a reboot nothing changed and my resolution is still horribly dystopic.... – fowlslegs Feb 23 '13 at 17:56
So I tried a couple other things. Bumblebee makes it impossible to run nvidia-xconfig; when run it displays an error saying package is not found even though nvidia-settings says to run it as root still. I still cannot find it in additional drivers and sudo jockey-text -e kmod:nvidia_current said driver could not be installed. I also edited the xorg file related to bumblebee and pointed it to the nvidia driver instead of nouveau, although maybe I did this step wrong.... – fowlslegs Feb 23 '13 at 17:57
Please see: Askubuntu limits post length, but I have put some more information up there which may be valuable. – fowlslegs Feb 23 '13 at 19:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.