Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04.02 x64 and KDE 4.10.00.
I'm having a little video tearing while playing ANY video (HD mkv, avi, etc.).

  • it happens with vlc latest version and with default Ubuntu video player and also with other players like kmplayer.
  • I have some effects enabled and I use: OpenGL, Raster, Shaders: OpenGL 2 and vertical sync.
  • I have ATI MSI R6870 hawk with latest fglrx video card driver AMD Catalyst™ 13.1 Proprietary Linux Display Driver
  • My pc hardware are:
    CPU: Intel(R) Core(TM) i5-2500 Sandy Bridge
    Motherboard: Asus P8P67 PRO
    Display: full hd display (DVI)
  • glxinfo says direct rendering: yes
  • No problem with Windows 7.

How to solve it?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The AMD Catalyst software has an option to reduce tearing.

Open a terminal and type kdesudo amdcccle, then find the section for reducing tearing and check the option.

Additionally, I should mention that I had some tearing issues with VLC and Totem a while ago (before the 13.1 driver was released), but using smplayer instead of VLC dramatically improved my video playback. If the Catalyst option doesn't work for you, give smplayer a try and see if that helps.

share|improve this answer
    
wow, it just solved my problem. The ati option works great so even vlc doesn't make tearing. And smplayer is even better. thanks Btw does this ati option makes my video card work more? –  Frank Feb 27 '13 at 19:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.