Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've finally gotten my wifi working on my Macbook Pro 9 2 (Fully booted with Ubuntu 12.04 64-bit) ,but it is only working on the Broadcom STA/WL driver that comes with this version of Ubuntu. I've been all over the forums on the web and I've gathered that this driver doesn't support Monitor Mode, but the b43 driver that is already installed on my computer does.

03:00.0 Network controller: Broadcom Corporation BCM4331 802.11a/b/g/n (rev 02)

I've tried:

rmmod -r wl
rmmod -r b43
modprobe b43

and also tried blacklisting the wl driver. All it does is completely ignores the fact that I can use wireless. No "firmware missing" or anything like that. It's just not there. I know that b43 supports the bcm4331 card I have, but it isn't.

This is all the information I can think to give, but of course if I have left anything useful out just tell me. Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

i suggest you the first thing I done with my wifi card rfkill unblock all

or try to compile the last stable kernel on your hardware (worked for me with 10.04)

share|improve this answer
    
I tried the rfkill and it didn't change anything. I tried rmmod wl and modprobe b43 afterwards and I restarted, but wl was running when I rebooted. Thanks for your help man, I've been trying to get this thing working for hours. –  Joseph Paul Langford Feb 22 '13 at 18:40
    
how about the new kernel Full source? –  Benvert Adam Feb 22 '13 at 23:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.