Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am installing Ubuntu Server 12.04.2 LTS 64Bit. Everything is fine up until it gets to "Configuring apt" and it is stuck at "Retrieving file 61 of 69".

I left it on for 6 hours now and is still stuck at that same point.

I have tried restarting the installation with network cable disconnected, I have tried skipping this step by clicking the only available button "cancel" but then it fails later in the process. (I can't remember where)

Some people said to try and open another terminal CTRL-ALT-F2 and do "ifconfig eth0 down" but when I tried that it says "ifconfig" is not a command... nothing really works actually, not even "man".

configuring apt

share|improve this question
    
What virtual machine are you using? Have you tried using an alternative (such as VirtualBox), or installing it 'on the metal' (e.g. a direct installation)? –  InkBlend Feb 22 '13 at 18:26
    
@InkBlend Hi!, I'm using Vmware ESXi 5.1 Unfortunately i don't have a choice in this matter, it must be ESXi. –  7wp Feb 22 '13 at 18:30
    
you might want to try using another VM anyway, not for actually using it, but determining if the problem is with Ubuntu or the VM itself. –  InkBlend Feb 22 '13 at 18:32

5 Answers 5

up vote 4 down vote accepted

Don't be so stingy with the disk space. I was having the same error and resolved it by going to 2.5GB.

share|improve this answer

I was attempting to install 12.04.2 onto an IBM X345 server, dual Xenon 3.066MHz and 4 gigs of ram, 5 disc scsi raid array. Same deal, kept hanging configuring apt. Tried various net paths, http, FTP, to no avail. I updated the server's bios, and tried the install again. It went fast and flawlessly, even did the samba install and all updates. I hope this helps out some people, I was going crazy for about 3 hours!

share|improve this answer

Ok, this will sound very strange but I had the exact same problem and managed to solve it. I solved it by clicking the Cancel button... Before that i had it re-installed multiple times but that didn't work. After i clicked the cancel button it went on installing very fast and i was done in 5 minutes.

share|improve this answer

if you are installing ubuntu server in a vm, on ubuntu splash screen after you have selected your language, press F4 to open mode menu and select install a minimal virtual machine. proceed on to installing the os, then it won't hang on configuring apt.

share|improve this answer

The OP reported in a comment on another answer that switching from the 64-bit version of Ubuntu Server to the 64-bit version solved the problem:

I gave up, I ended up installing the 32bit version and that seemed to work.

7wp Feb 26 '13 at 5:44

Since 64-bit software usually takes up a bit more disk space than 32-bit software, it occurs to me that it makes sense that either this or Nobody's answer might solve the problem.

The post where this was posted may be deleted, as it was posted as an answer but doesn't really answer the question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.