Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.10 64 bits with Unity.
When I restart or shutdown the PC, it takes too long to do it.
It shows the line Asking all remaining processes to terminate... [fail] and after Killing all remaining processes.
How can I debug this to determine the origin of the problem?

share|improve this question
    
I have similar issues that occasionally get solved with upgrades or package removals... I'd be interested to find out the errors in some log files, but I never found anything related... –  jasmines Feb 22 '13 at 12:57

2 Answers 2

I was experiencing the same behaviour when using a NAS (samba share) with fixed mounting points. It was caused by some kind of race condition between the unmounting process and network-manager during termination stage on shutdown. Here's a small workaround that fixed it for me:

Fire up a terminal by pressing Ctrl + Alt + T and paste these commands:

sudo mv /etc/rc0.d/S31umountnfs.sh /etc/rc0.d/K15umountnfs.sh

sudo mv /etc/rc6.d/S31umountnfs.sh /etc/rc6.d/K15umountnfs.sh

This simply moves the unmounting process up the priority list when shutting down or rebooting the system. At least my system is shutting down very fast again without errors.

Good luck!

share|improve this answer

I had the same problem with Ubuntu 13.04 running virtual in VMware player. I tried Ctrl + Alt + T (I didn't expect a console and it doesn't show any), and all the sudden the installation continues!

I already tried Esc, Ctrl + C, Ctrl + break, but this had no effect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.