Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

here's my problem. When I log in I'm beeing asked for a password connecting to the internet which is strange because I'm the only user and the admin. I have auto log in and it never asks for passwords, (except when i do administrative tasks.) I have looked in the menu (System --> preferences, but i can't find any topic that say's passwords or similar. the only place where I have found a way to change my password is my user ((System --> preferences --> user and groups). I did try to take screenshots but nothing happened, which also is strange.

I'm running ubuntu 10.04 LTS Desktop on my Asus 1201n (12").

share|improve this question
2  
Are you connecting via wireless or wired connection. I had this same problem with a wireless connection when I was set up for auto login. I think the problem is that the WPA password for the wireless connection is stored on your ubuntu account's key ring, and since you did not authenticate when logging in, you need to authenticate when trying to bring up the network connection. You might try changing the configuration of your connection in Network Manager to be available for all users and this may allow the connection without you needing to be authenticated to use it. –  Dennis VanMeter Feb 12 '11 at 16:11
    
thanks this works! I canged all the passwd with (sudo passwd) after I did what you said. –  Alvar Feb 12 '11 at 18:20
    
I've voted up Dennis's comment - suggest you do the same. Should have been an "answer" though and would therefore have claimed the "accepted" reputation too. –  Scaine Feb 12 '11 at 18:31
    
how do i up vote the comment? –  Alvar Feb 12 '11 at 19:00
    
I didn't want to post my suggestion as an answer since it was just speculation and could not test it myself. I'm glad it helped! –  Dennis VanMeter Feb 13 '11 at 4:50
add comment

3 Answers

up vote 2 down vote accepted

It's also possible that since your using auto-login, you might be hitting another problem - sometimes network manager doesn't seem to save the WEP/WPA key properly. You can usually get round this by opening the connection and changing it "available to all users".

So, right click on network manager, choose "Edit Connections". Find your connection, and choose "Properties", then tick the "Available to all users" box at the bottom.

enter image description here

share|improve this answer
    
This answer is the same as the comment is on my first post. But it works! woho! –  Alvar Feb 12 '11 at 18:14
    
True. Didn't think it was the same issue though, so I put two answers to cover both possibilities. Answers shouldn't be made in comments (although sometimes it just happends!) - only "answers" can be "accepted". –  Scaine Feb 12 '11 at 18:29
    
well we have to just up vote the comment then.. :) –  Alvar Feb 23 '11 at 12:35
    
There is only one user so LOL –  Alvar Jun 8 '11 at 12:10
    
That's irrelevant, really - the main thing is that ticking that box bypasses the use of gnome-keyring for saving your password. Instead, it's dumped in a root-only-readable file somewhere in /etc. It's less secure, but seems more reliable. Having said that, I haven't seen this "bug" since Lucid LTS 10.04. Maverick 10.10 has been fine for me. I haven't upgraded to Natty 11.04 yet, so can't comment. –  Scaine Jun 8 '11 at 13:40
add comment

Sounds like your keychain is out of sync with your password. Go to System/Preferences/Password and Encryption keys, then choose the "login" chain.

Seahorse

The only way that I know works is to set this to a blank password - you will be prompted on whether you are willing to trust this "unsafe storage" method, since your keyring will unlock automatically on login.

I think you can also match the password on the login keychain to match that of your login password. But a) I haven't tested that and b) you have to remember to change your keychain password whenever you change your login password.

As the only person on my laptop, configured with encrypted home, I'm happy with unsafe storage, but your mileage may vary.

share|improve this answer
    
I don't have a menu trail that leads to a password and encription key! My menu start with personal file sharing and over that is a openjdk java. –  Alvar Feb 12 '11 at 17:39
    
It's possible that "Passwords and Encryptions keys" is still in the Applications/Accessories menu for you. It was moved in 10.10, I think. Could be wrong. You can open a terminal and do sudo apt-get install seahorse to install it if you don't have it. –  Scaine Feb 12 '11 at 18:26
    
You may still have this in Applications/Accessories. If you can't it there either, try using ALT-F2 and enter seahorse. If that doesn't work, you don't have it installed. Use sudo apt-get install seahorse to install it. –  Scaine Feb 12 '11 at 18:30
    
haha, it is under applications accessories! awesome! –  Alvar Feb 12 '11 at 18:51
    
It was changed to system/preferences in 10.10, I think, which makes sense now that I notice you're running 10.04. –  Scaine Feb 12 '11 at 20:37
show 1 more comment

In order to change the root password, open a terminal

sudo passwd

When asked, provide your user password in order to perform sudo tasks, then enter the "new UNIX password" twice.

Now the root user has a new password.

You will see something like this:

geppettvs@HANNAH:~$ sudo passwd
[sudo] password for geppettvs: 
Enter new UNIX password: 
Retype new UNIX password: 
passwd: password updated successfully
geppettvs@HANNAH:~$

Good luck!

share|improve this answer
    
If you're using encrypted home, this will break your install. You should use the Me Menu to change your password. –  Scaine Feb 12 '11 at 16:54
    
It didn't broke with mine, but thanks for the warning. –  Geppettvs D'Constanzo Feb 12 '11 at 17:21
    
And you're using encrypted home too? –  Scaine Feb 12 '11 at 20:39
    
Yes I do. :) :) :) –  Geppettvs D'Constanzo Feb 13 '11 at 23:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.