Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want my laptop not to turn off monitor when on AC power under any circumstance.

And yet it becomes dark after a while - 10 minutes I guess.

I think the Xfce GUI settings involved are these here:

enter image description here

I am used with this type of behaviour in some Xfce system programs, they do not seem to have matured enough and have many aspects that need to be adjusted, usually there are some manual tweaks or workarounds for this.

Or maybe is this related to a screensaver?

What to do?

share|improve this question
most probably i had no screensaver gui installed but somehow a screensaver daemon was active, i have just installed xscreensaver now where i see an option to disable screensaver. i'll see and report and eventually edit an answer or suggest an edit. nevertheless the xfce power manager is ridiculously inefficient here, even if the blank screen is a "screensaver" that should be reflected in the power options too. xfce is still far from the support and development of gnome/unity. in some aspects is worst than LXDE, but i keep it for its good looks – cipricus Feb 22 '13 at 12:03
up vote 1 down vote accepted

This could be a screensaver. Take a look at the screensaver-settings (xscreenserver). There is one screensaver which just fades the screen to black.

Edit in order to set as definitive answer:

There was no screensaver gui installed but somehow a screensaver daemon was active.

Installing xscreensaver, and running 'Screensaver' there is an option to disable screensaver.

enter image description here

'Screensaver' ("Screensaver Preferences") appears in main Menu/Settings in Xfce and among 'usr/share/applications'.

A solution with a wider scope - HERE, specifyng also that for the above solution to work, Screensever (xscreensaver -no-splash) has to be added to the startup programs list. The problem may very well be caused in the first place by just disabling Screensaver in the Applications Autostart list.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.