Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 in combination with Awesome window manager. Most of the stuff ubuntu provides I don't use.

I adjust my audio volume through scripts with amixer or manually with alsamixer. However after a reboot, my audio is muted and the only way to unmute it is through the gnome-control-center sound GUI.

I prefer terminal so I would like to know how I can unmute my audio without having to open up a GUI. Also, should I maybe remove pulseaudio, since I always use alsamixer anyways?

share|improve this question
    
Check out this question, as for pulseaudio, remove if you don't use it. –  mikewhatever Feb 22 '13 at 10:02
    
After muting with Alsa mixer and keeping it like that for just over an hour I had my sound ununmuteable via Alsa mixer. A suspend-wake didn't help. @Takkat's answer did. (Ubuntu 12.04) –  valid Mar 4 at 16:44
add comment

2 Answers 2

up vote 2 down vote accepted

In case we want to keep pulseaudio we may also unmute a sink from the command line.

By using the Pulseaudio Command Line Interface we will get the index of available sinks

pacmd list-sinks

We then can unmute the sink with

pacmd set-sink-mute <index> 0
share|improve this answer
    
For a more compact list you might want to use: pacmd list-sinks|grep "index:\|name:\|muted:" –  valid Mar 4 at 16:38
add comment

If the problem is that every time your reboot you need to unmute then you can avoid the problem completely by unmuting manually once then run

sudo alsactl store

Next time you reboot, your settings will be automatically restored.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.