Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to install over the top of my 32bit ubuntu 12.04 successfully. I start out with win7 64bit and ubuntu 12.04 32 bit installed and working/booting without a problem . I decided to go to ubuntu 64 because of issues i was having with nvidia and xorg stuff.

First I backed up my C drive using acronis true image 2013, so i could start over (as i have had to do everytime).

My C drive (an intel ssd 80gb drive) looks like this before i attempt the 32 to 64 ubuntu install. sda1 100MB boot partition
sda2 55GB NTFS Windows 7 install directory
sda3 5.5GB ext4 / (root)
sda4 8.2GB ext4 home

The swap file for ubuntu is on a different drive and so is the windows page file.

My system is a core i7 950 with 12gb ram so i havent actually ever exploited paging.

When i boot to a 12.04 64 bit DVD , I try the first choice (delete ubuntu and reinstall), i get a message saying the size of the partition for ' ' should be 2.4 or larger, and that i should change it be that size at least.

When i boot to 12.04 64 bit DVD, and try the last choice (something else) , and then i just specify to format the 5.5gb partiton and make it "/" as mount point and format it. Also i specify to use the 8.2GB drive as /home (no format). I run the install but when i restart i get an error saying the UUID is not found and grub prompt....ugh!!!

I then used Acronis started over. everything back to functioning with 32bit..

Tried boot to 12.04bit DVD, again try last choice (something else), and then i play with the boot disk parm .. no matter what i do i get the UUID not found and a grub promt...

In both cases i can PF12 and tell the system to boot from my hard drive and I get the grub menu and can go into ubunto , but if choose the windows install it redisplay the grub menu.

Seems like MBR is screwed up in all cases, not sure where i can go from here.

Reinstall from acronis backup and ????

Have gotten nowhere on this.

share|improve this question
    
This seems like one of those strange installation/upgrade issues. Have you tried simply booting your 64-bit Ubuntu DVD (try without installing) and start GParted, format sda3, and then reboot to install to a clean partition? –  Sadi Feb 22 '13 at 9:41
    
I will give that a shot, although it doesnt seem much different from what i am doing now, and what i am trying to do seems like it should work correctly. The 3rd choice something else, lets you format and install the drive and install in one step, and it installs it correctly it just does a bad job of dealing with the MBR. I will try doing in seperate steps and post what happens. Thank you for replying. :-) –  user134489 Feb 23 '13 at 5:19
    
Sadi - I tried what you said. I booted to ubuntu , ran gparted to format the drive that ubuntu was on. Upon reboot i get the grub error saying the uuid doesnt exist, and i cant boot to windows either. So i guess part of the information needed to boot to either system was on the drive?? What next?? I am going to boot from the cd and tryin installing the 64bit version on the partion i just formatted. –  user134489 Feb 24 '13 at 4:18
    
Same problem .. what can i do? –  user134489 Feb 24 '13 at 5:14
    
Can you boot to ubuntu 64-bit you've just installed? As you say "can F12 and tell the system to boot from my hard drive and I get the grub menu and can go into ubuntu, but if choose the windows install it redisplay the grub menu." Then it is probably because UUID number of your Windows drive has changed and somehow it's not being updated. You can first try again updating grub in your Ubuntu installed on your hard disk (no dvd) with terminal command sudo update-grub and reboot. If the problem persists you can try manually modifying it with terminal command sudo gedit /boot/grub/grub.cfg –  Sadi Feb 24 '13 at 8:50

1 Answer 1

I was still able to f12 and get the bios boot menu, when i select my c drive from there the grub menu would come up and I was able to select windows or ubuntu successfully. update-grub and edit grub.cfg didnt solve anything. What i found was that in the bios the order of the hard drives had a non bootable drive first in the list (ahead of the c drive), this didnt cause any problems with win7/ubuntu 32 bit, only grub that is part of ubuntu 64. I changed the order of the drives so my 'c' was first in the list and that fixes the problem. I think ubuntu should figure out why grub fails in this situation, its as if it looks at the drive that is first in the bios list and checks to see if its a certain uuid. the order the bios list has for hard drives has nothing to do with the price of bananas.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.