Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have honestly spent at least 6 to 8 hours trying to get this to work. Here's what I've got.

Ubuntu-server file server Rasberry Pi with Xbian Several Windows 7 Machines

I've set up a samba share on the ubuntu server. I can access it from the Windows Machines without logging in at all but I have to manually type the address (\Gandalf\Shares). It doesn't show up in my network automatically (I'd like it to but whatever).

The problem I'm having is accessing it from XBMC. I can't access it from my Rasberry or XBMC on my windows machines no matter how I try to get to it. It seems like I get a different error everytime.

Here's the kicker, When I first got my rasberry I set all this up and it all worked perfectly. I could see it on any windows 7 machine on the network and I could get to it right from the file manager in xbmc. It took me about 30 minutes of Googling and trial and error so I had no idea it would be so difficult to do again. But since then I reinstalled xbian on the pi and reinstalled Ubuntu-server on the linux box. Essentially, I started from scratch with the same config.

I'm really pulling my hair out over this. Any suggestions would be greatly appreciated.

Here's my smb.conf file

[global]
    ; General server settings
    netbios name = Gandalf
    server string =
    workgroup = FELLOWSHIP
    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_$
    passdb backend = tdbsam
    security = user
    username map = /etc/samba/smbusers
    name resolve order = hosts wins bcast

    wins support = yes

    syslog = 1
    syslog only = yes

    map to guest = bad user

; NOTE: If you need access to the user home directories uncomment the
; lines below and adjust the settings to your hearts content.
;[homes]
    ;valid users = %S
    ;create mode = 0600
    ;directory mode = 0755
    ;browseable = no
    ;read only = no
    ;veto files = /*.{*}/.*/mail/bin/

; NOTE: Only needed if you run samba as a primary domain controller.
; Not needed as this config doesn't cover that matter.
;[netlogon]
    ;path = /var/lib/samba/netlogon
    ;admin users = Administrator
    ;valid users = %U
    ;read only = no

; NOTE: Again - only needed if you're running a primary domain controller.
;[Profiles]
    ;path = /var/lib/samba/profiles
    ;valid users = %U
    ;create mode = 0600
    ;directory mode = 0700
    ;writeable = yes
    ;browseable = no

[Shares]
path = /shares
browseable = yes
read only = no
guest ok = yes
#create mask = 0775
#directory mask = 0775
writeable = yes
available = yes
share|improve this question

1 Answer 1

Not sure if you ever got this figured-out, but when I was setting up shares in Ubuntu 12.04 I had to do a couple things before I was able to see them from a Windows machine:

  1. Create a Samba username and password (sudo smbpasswd -a USERNAME)
  2. In the file manager (not sure if that's the right name), on the Linux machine I set the permissions to Owner, Group, and Others. And set the Access to Create and Delete Files.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.