Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to install the new Ubuntu Phone SDK using the instructions here: http://developer.ubuntu.com/resources/app-developer-cookbook/mobile/currency-converter-phone-app/

Unfortunately when I run Qt-Creator it says a bunch of plugins failed to load:

Cannot load plugin because dependency failed to load: ProjectExplorer(2.6.82)
Reason: /usr/lib/x86_64-linux-gnu/qtcreator/plugins/QtProject/libProjectExplorer.so: Cannot load library /usr/lib/x86_64-linux-gnu/qtcreator/plugins/QtProject/libProjectExplorer.so: (libQt5Declarative.so.5: cannot open shared object file: No such file or directory)

Is there a missing step in the instructions, is something wrong with my setup, or is this not yet working in 12.10?

share|improve this question
2  
libqt5declarative5 is install correct ? –  Joseph Mills Feb 22 '13 at 4:06
    
That was it, thanks! Hopefully the final Ubuntu Phone SDK will have updated dependency info so that doesn't happen. –  NoBugs Feb 23 '13 at 3:42

2 Answers 2

Run:

sudo apt-get install libbotan*
share|improve this answer

Had the same problem. The error message also contains the answer. There is a missing libbotan*.so. So it is a missing dependency problem in the qtcreator package.

sudo apt-get install libbotan-1.10-0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.