Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, my Internet intermittently disappears. I have no idea why!

For a while I thought it happened when I allowed Update Manager to auto-check for updates, but I don't believe that's the case now.

Here's the thing, is I don't know how to check my computer's activity log to try and discern why this would happen, or what to look for once I've done so(or, how to re-post it here, so someone much smarter than me could figure it out). How do I properly troubleshoot this?

EDIT: I've bolded what I'd like to emphasize here. While I appreciate the suggested fix, I've noticed an apparent change in my computer's behavior - since I turned off the rotating desktops feature, I have experienced no connection issues. Since this is a somewhat random occurrence at this time I do not want to assume a correlation between my Appearance settings and my ability to stay connected to wifi. So how do I investigate?

EDIT2: Okay, so, this is still an apparent issue on Ubuntu 13.04 so I've removed the 12.04 tag as it doesn't appear to apply. It seemed to be away for a while, but it is back, maybe as a result of upgrade (but I had to, Unity is just so much faster! Eee) So far I have been able to reconnect by going to System Settings > Network > select my network and right the orange arrow > Settings > toggle the MTU setting from "Automatic" to "1" and back to "Automatic" and save. If the problem is indeed this setting, the method described in the other post is not indicative of how to find the correct MTU setting. Is there a way for me to determine the best MTU? As an aside, this is not a problem for the Windows or OSX machines on my home network, just this guy :(

EDIT3: Per the request below, here's the output from dmesg | tail:

[   18.209158] wlan0: associate with 00:1e:e5:74:26:0f (try 1/3)
[   18.213191] wlan0: RX AssocResp from 00:1e:e5:74:26:0f (capab=0x411 status=0 aid=4)
[   18.213241] wlan0: associated
[   18.213273] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2227.016921] init: upstart-file-bridge main process (319) terminated with status 1
[ 2227.016961] init: upstart-file-bridge main process ended, respawning
[ 2227.017109] init: upstart-udev-bridge main process (346) terminated with status 1
[ 2227.017127] init: upstart-udev-bridge main process ended, respawning
[ 2227.017242] init: upstart-socket-bridge main process (617) terminated with status 1
[ 2227.017259] init: upstart-socket-bridge main process ended, respawning

EDIT4: Ok, so it looks as though I might have something here. Take a look at this message:

[   16.688255] wlan0: authenticate with 00:1e:e5:74:26:0f
[   16.700191] wlan0: send auth to 00:1e:e5:74:26:0f (try 1/3)
[   16.703235] wlan0: authenticated
[   16.703460] ath9k 0000:02:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   16.703494] ath9k 0000:02:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   16.710006] wlan0: associate with 00:1e:e5:74:26:0f (try 1/3)
[   16.713175] wlan0: RX AssocResp from 00:1e:e5:74:26:0f (capab=0x411 status=0 aid=4)
[   16.713234] wlan0: associated
[   16.713266] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 3170.516163] systemd-hostnamed[3772]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

I Googled that last line about nss-myhostname and I got a bunch of hits regarding all kinds of other Linux distros, just not really anything about Ubuntu :/ Is this relevant at all?

share|improve this question
    
See if this answer helps: askubuntu.com/a/60321/25656 –  user25656 Feb 22 '13 at 7:25
1  
As soon as you notice it drops out run dmesg | tail in a terminal, and see what output you get. –  handuel Apr 28 '13 at 20:17
    
updated main post to include dmesg | tail –  Stick Apr 28 '13 at 22:04
    
Are you up and running now? –  Freedom_Ben May 6 '13 at 15:53
    
@Stick, you mean you have an internet connection for a minute and the you don't have an internet connection for 5 minutes? I have this problem but it is related with lan askubuntu.com/questions/305971/… –  ilhan Sep 22 '13 at 22:15

3 Answers 3

up vote 5 down vote accepted
+50

I was having a similar problem with mine, that turned out to be a two-part problem with interference from eth0 (the wired ethernet port) and a slight incompatibility between Linux and my wireless router's implementation of 802.11n.

If you are running the Intel wireless driver (iwlwifi), try typing the following commands at a terminal. These will turn off your ethernet port and disable the wireless N in the wifi driver. It is not permanent and will revert the next time you reboot:

sudo ifconfig eth0 down
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

If that works for you, there's a bash script on my Github that you can download and run each time you reboot: https://github.com/FreedomBen/handy-bash-scripts/blob/master/fixTheInternet.bash

I have this script on my desktop and I just run it each time I reboot. I haven't had any issues since.

Note: You will have to make the script executable. At a terminal, type:

cd path/to/script
chmod +x fixTheInternet.bash
share|improve this answer

If the MTU is the problem, you can get some tips about finding the correct value here. Generally speaking though, a value of 1500 is pretty standard.

You can set the MTU for your wifi connection as follows:

sudo ifconfig {wifi-interface} mtu {mtu-value}

So if your wifi interface is wlan0 and you want an MTU of 1500, it would be:

sudo ifconfig wlan0 mtu 1500

If this works for you, you can make it permanent by putting the value that worked in /etc/network/interfaces

share|improve this answer

The way I solved this problem(only happened at school network, home and others were fine) was "magical"

  1. I disabled wireless network adapter.
  2. Erased all connection profiles(eth, wlan, mobile...) trough network manager applet.
  3. Reboot.
  4. Re-enabled wireless adapter.
  5. Reboot (I know I come from windows and am noob with Ubuntu)
  6. Connect again.

I have been working for a while with no problems. (I dont know why but if someone figure it out please tell me)

share|improve this answer
    
You may have been seeing the same problem I was. You may want to try the steps I detailed in my answer below. It might fix your problem so you don't have to reboot or disable adapters manually and clear connection profiles. –  Freedom_Ben Apr 30 '13 at 16:37
    
@Freedom_Ben i did that once and no problems since, was like a month ago, still no major/critical updates were installed so i dont know when the problem will occur again –  mf_ Apr 30 '13 at 16:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.