Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 and tried to update ubuntu-sdk but today it wasn't possible without adding phablet-team/tools PPA as described here https://wiki.ubuntu.com/Touch/Install#Step_1_-_Desktop_Setup I did that and updated ubuntu-sdk. After that when I was trying to start Qt Creator I got following error:

http://screencloud.net//img/screenshots/72d93a81eef1d525afc5f82d7cc61790.png

So I decided removing and installing ubuntu-sdk again might be a good idea. Unfortunately it was not. When installing I got error messages. And if I try to fix it via USC I have following:

installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 189383 files and directories currently installed.)
Unpacking libqt4-dev (from .../libqt4-dev_4%3a4.8.1-0ubuntu4.4_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libqt4-dev_4%3a4.8.1-0ubuntu4.4_i386.deb (--unpack):
 trying to overwrite '/usr/bin/uic3', which is also in package qtchooser 0.0.1~git20121229.g8f08405-0ubuntu1~precise1~test5
No apport report written because MaxReports is reached already
dpkg-deb (subprocess): subprocess data was killed by signal (Broken pipe)
dpkg-deb: error: subprocess <decompress> returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-dev_4%3a4.8.1-0ubuntu4.4_i386.deb
Error in function: 
dpkg: dependency problems prevent configuration of libqtwebkit-dev:
 libqtwebkit-dev depends on libqt4-dev (>= 4:4.8.0~); however:
  Package libqt4-dev is not installed.
dpkg: error processing libqtwebkit-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl-dev:
 libqt4-opengl-dev depends on libqt4-dev (= 4:4.8.1-0ubuntu4.4); however:
  Package libqt4-dev is not installed.
dpkg: error processing libqt4-opengl-dev (--configure):
 dependency problems - leaving unconfigured
share|improve this question
add comment

1 Answer 1

$ sudo apt-get install libbotan-1.10-0

will help

share|improve this answer
    
Thanks but it didn't work. I could not install or uninstall anything. Always get message about error and suggestion to run sudo apt-get install -f Finally I ended up reinstalling my machine. –  mivoligo Feb 22 '13 at 17:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.