Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Mates. I was wotking with a pdf on Drawer, LO crashed and didn't came back to work.

When I try to load it from the console i get this error:

UNO Exception: InvalidRegistryException: file:///usr/lib/libreoffice/program/../share/extensions/pdfimport/components.rdb: 
duplicate <implementation name="com.sun.star.comp.documents.HybridPDFImport">
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'

I've tried uninstalling and installing back.

Any ideas?



I solved it!

I've renamed extensions folder under /usr/lib/libreoffice/share, and it came back. Gotta see if the pdf extensions is still working, but now at least i can run libreoffice.


share|improve this question
Please add your answer as an answer and accept it so this gets marked 'answered'. Thanks! –  Seth Feb 21 '13 at 21:37

2 Answers 2

See what's in your ./libreoffice/program/share/extensions after uninstalling/reinstalling. Good luck bud!

else, you could check this out: Bug

share|improve this answer
I don't have any libreoffice folder on my home directory –  Pablo Feb 21 '13 at 21:04
It is a hidden folder. Press ctrl + h to show hidden files and folders starting with a dot. –  To Do Feb 21 '13 at 21:07
I know, but I don't have a libreoffice folder –  Pablo Feb 21 '13 at 21:10
I looked under /usr/share/libreoffice/share/, and there's no extensions folder –  Pablo Feb 21 '13 at 21:22

Use Synaptic package manager and search for openoffice-pdfimport and mark it to be removed and apply Libre Office started up immediately! Though in Software Center / History It showed I removed libreoffice-pdfimport(1.0.6+lib03.6.2~rc2-0ubuntu4)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.