Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04. on my Dell Inspirion Mini 1018. After doing one of regular updates, my wifi stopped working, and it gives me message Wireless is disabled by hardware switch.

How can I enable it? I tried opening network connections, but there I find: Wireless Unavailable. Hardware Address 1C:65:9D:68:9E:6B

Then I tried System testing, it gives me a message:

# For some Atheros 5K RF MACs, the madwifi driver loads buts fails to
# correctly initialize the hardware, leaving it in a state from
# which ath5k cannot recover. To prevent this condition, stop
# madwifi from loading by default. Use Jockey to select one driver
# or the other. (Ubuntu: #315056, #323830)
  blacklist ath_pci"

This what I get after nm-tool :

Type: 802.11 WiFi
Driver: rtl8192ce
State: unavailable
Default: no
HW Address: 1C:65:9D:68:9E:6B

Capabilities:
Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points

Next command I used sudo lshw -C network

*-network DISABLED
description: Wireless interface
product: RTL8188CE 802.11b/g/n WiFi Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:07:00.0
logical name: wlan0
version: 01
serial: 1c:65:9d:68:9e:6b
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8192ce driverversion=3.2.0-37-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resources: irq:17 ioport:3000(size=256) memory:f0100000-f0103fff

As I am new on Ubuntu, I asked on Newbees forum, and here is what i did so far

http://ubuntuforums.org/showthread.php?t=2116769

One who was guiding me has no idea what to try next.

share|improve this question
    
this is rough. In the thread they suggest to reset BIOS to default settings. Did you do that? If not, restart your computer and hold Ctrl-F11 immediately after startup. –  phipsalabim Feb 21 '13 at 14:14

1 Answer 1

I'm not sure but I'm guessing this has nothing to do with Ubuntu: you have to press some keyboard key to activate the card (for example, Fn+F12 keys)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.