Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 32bit with the intention of using it to share hard drives across an office of Windows 7 computers. I've set up an initial share on the hard drive Ubuntu was installed from with no issues - Windows can see, read and write to this drive. I did this using the GUI (Right click > Properties > Share) and a small amount of editing Samba's preferences.

My problem came when I added a second drive. I've formatted it as ext4 and mounted it, and shared it through the right click menu as before. However, though Windows can see the folder, when I try to access it I get a "Windows cannot access..." permissions message. This only happens on the second drive.

If it's of any help, here's my fdisk -l:

    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000b4feb

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048  1928376319   964187136   83  Linux
/dev/sda2      1928378366  1953523711    12572673    5  Extended
/dev/sda5      1928378368  1953523711    12572672   82  Linux swap / Solaris

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1  1953525167   976762583+  ee  GPT

It's the disk at "dev/sdb1" I'm attempting to share.

I also tried manually adding this to my fstab, but this doesn't change things one way or the other:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=8aea5b44-a5f0-4d0e-8e22-53c3838a8ede /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=5d4ac6d9-a9a1-4ed6-bee5-ab72fed15b12 none            swap    sw              0       0
/dev/sbd1 /media/revolution/data ext4 defaults 0 0

Any help would be greatly appreciated.

share|improve this question
    
/dev/sbd1? What is that in your fstab? Don't you mean /dev/sdb1? –  saleemrashid1 Feb 21 '13 at 13:22

1 Answer 1

up vote 2 down vote accepted

Find the UUID for /dev/sdb1 with

blkid

Then edit your fstab and add the UUID and the mount options rw,auto,user,exec.

# /media/revolution/data was on /dev/sdb1
UUID=xxxxxxxxxxxxx  /media/revolution/data  ext4   rw,auto,user,exec   0      2
  • rw = read/write
  • auto= automount at boot
  • user= any user can mount/access the directory
  • exec= allows executables to run
share|improve this answer
1  
That fixed it - thanks for your help, and your clear explanation of what each option does. –  BiscuitBaker Feb 22 '13 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.