Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem when configuring samba

I manage to login to samba and create a folder and configure it t share.

I can see the the folder on my windows machine but when trying to click in it it says that i have no permissions

I have added acess to all users on samba config

should i try to remove and re-install samba? if so would be the command?

could it be an issue with the actual drive permission that the folder is at?

When i try to do it from the GUI in Ubunutu(bypassing samba) i get error net usershar:cannot pen usershare directory error permition denied

any ideas?

thanks

share|improve this question
    
can you provide the file permission on the shared folder? ls -lrt <folder_name> The folder should have read+execute permission for group and others. –  Vivek Feb 21 '13 at 11:27
    
what is the command t check that? :/ –  savio Feb 21 '13 at 11:33
    
sorry you already mentioned above o will check –  savio Feb 21 '13 at 11:33
    
change the permission of the folder to 775. chmod 775 <directory_name> . It should work then. –  Vivek Feb 21 '13 at 11:41
add comment

1 Answer 1

up vote 0 down vote accepted

A share-config in smb.conf can look like this.

[share]
path = /opt/share
valid users = <user>
read only = no
create mask = 0777
directory mask = 0777
readable = yes
writable = yes
browseable = yes

Did you added and enabled the user?

sudo smbpasswd -a <user>
sudo smbpasswd -e <user>

Make sure both processes "smbd" and "nmbd" are running:

sudo ps axu | grep smbd
sudo ps axu | grep nmbd
share|improve this answer
    
how do i completely uninstall the samba so i can re-install –  savio Feb 21 '13 at 21:16
    
this is what i get when i run sudo ps axu command 1000 8662 0.0 0.0 4396 832 pts/7 S+ 21:13 0:00 grep --color=auto smbd –  savio Feb 21 '13 at 21:18
    
i think the best option is to un install and re install. if so do i have to reboot the server? –  savio Feb 21 '13 at 21:19
    
i have used the purge command and now got rid of samba however the files still on /etc/samba there are 3 files there... sh ould that have not been removed as well with the unintall –  savio Feb 21 '13 at 21:31
    
I manage to re-install samba but when i run the command rpm -qa | grep samba i do not get any output also if i try sudo apt-get install samba i get the following output root@22cansSRV1:~# sudo apt-get install samba Reading package lists... Done Building dependency tree Reading state information... Done samba is already the newest version. The following packages were automatically installed and are no longer required: linux-headers-3.5.0-17 linux-headers-3.5.0-17-generic Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded. –  savio Feb 21 '13 at 21:59
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.