Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Windows XP, inside BOOTMGR (I don't know why it isn't NTLDR, the PC just came like that), and have installed Wubi. When I boot up, BOOTMGR (Windows Boot Manager) still shows only Windows and System Restore, same as it did before, and times out after 5 secs.

What my question is, is how do I get Ubuntu to show in that list?

My boot.ini file, as requested:

[boot loader]
timeout=60
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptOut
C:\wubildr.mbr = "Ubuntu"

although I believe this info is irrelevant as I am running inside BOOTMGR, not NTLDR, for which boot.ini is the settings file.

bcdedit results in Windows XP Command Prompt:

C:\Documents and Settings\[my username]>bcdedit

'bcdedit' is not recognized as an internal or external command,
operable program or batch file.
share|improve this question
    
Please edit your post with the contents of your C:\boot.ini file. Thanks –  bcbc Feb 21 '13 at 17:18
    
Possible duplicate of: askubuntu.com/questions/75314/… –  bcbc Feb 21 '13 at 17:57
    
This is not a duplicate - as you can see the NTLDR timeout is 60, although the BOOTMGR timeout is still at 5. –  Kieran Feb 21 '13 at 21:23
    
Does it use BCD then? If so, what's the output from bcdedit? –  bcbc Feb 21 '13 at 23:04
    
Updated question - I guess this doesn't help, though. –  Kieran Feb 22 '13 at 15:16

1 Answer 1

You probably have two boot.ini files. On two separate partitions. The other has the boot flag set.

Because you mentioned that the Windows Boot Manager shows two options, Recovery and normal. And in your boot.ini there are two completely different option. I think the 'boomgr' thing is a red-herring. Even XP has the Windows Boot Manager, just it takes its entries from the boot.ini file.

What I'd do is, figure out which partition has the boot flag - not C:. Then modify it's boot.ini. You'd probably need to assign a drive mapping to the boot partition in order to do this as recovery partitions are typically hidden.

share|improve this answer
    
No, by BOOTMGR, I mean the Vist/7/8 bootloader, and by NTLDR I mean the Windows XP and earlier bootloader, which uses boot.ini, and is just text, compared to BOOTMGR's white background on the header and footer, not just the selected item, and used BCD. Note that if I want to get into Safe Mode, I have to quickly press F8 once the countdown reaches 0 or it will continue booting into the default Windows option. –  Kieran Feb 23 '13 at 11:12
    
Another note: In Computer Management (Right-click My Computer and choose "Manage", My HDD (Disk 0) has 2 partitions: System;4.88GB NTFS;Healthy (System) and Windows (C:);69.65GB NTFS;Healthy (Boot) so the boot partition is my C: drive according to Windows itself. –  Kieran Feb 23 '13 at 11:22
    
Okay... I guess what happened is you installed Vista (which replaces any old version of Windows boot manager) and then removed it later? In that case, you will need a Vista repair CD to modify the BCD store. Or you could repair your computer and replace the XP boot files. Obviously XP doesn't know anything about it, and cannot change it. –  bcbc Feb 23 '13 at 17:47
    
AFAIK, this in not the case, the PC is a re-manufactured HP Compaq dc7700p Small Form Factor. According to the "Designed for Windows XP" sticker on the front, the PC originally ran WinXP. Whether the mix-up happened when it was being re-manufactured, or it was a deliberate thing they did, I'm not sure, but I can get into NTLDR as BOOTMGR has to redirect pre-Vista OSes via NTLDR - if I can find a way to open the prompt through one of the F keys (F1,F2,.etc) –  Kieran Feb 23 '13 at 18:43
    
Have you tried asking on a Windows support forum? They might be able to help you figure out what's going on here. It seems like a non-standard setup and beyond my knowledge of Windows boot setup. –  bcbc Feb 23 '13 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.