Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I suspend my Xubuntu 12.10, and then take my computer off the suspension, it doesn't request any password. I have tried adding the gnome-screensaver on autostart settings, which I read somewhere (go to settings manager>sessions and startup>application autostarts>add [gnome-screensaver]), but that doesn't work.

How can I make my xubuntu request a password after suspension?

share|improve this question

1 Answer 1

up vote 12 down vote accepted

In Xubuntu 12.10, session is no longer locked when you Suspend, so it doesn't ask for a password on wakeup. To solve this, we need to make changes to xfce4-session and xfce4-power-manager.

Using Terminal Commands

Run the following commands in terminal (press Ctrl + Alt + T) to make changes to both xfce4-session and xfce4-power-manager to lock the session when you Suspend:

xfconf-query -c xfce4-session -p /shutdown/LockScreen -s true
xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/lock-screen-suspend-hibernate -s true

Alternatively — Using GUI

We need to make changes in both Session and Startup as well as Xfce Power Manager.

You would find both of them to be available under Settings Manager. Right Click on your Desktop and navigate through ApplicationsSettingsSettings Manager to open it.

xubuntu settings manager navigation

  1. Session and Startup

    Open Session and Startup → navigate to the Advanced Tab → put a checkmark next to Lock screen before sleep.


  2. Xfce Power Manager

    Open Xfce Power Manager → click on Extended in the sidebar → put a checkmark next to Lock screen when going for suspend/hibernate.


Once you have made the changes, you should be asked for the password when you wakeup after Suspend.

Acknowledgement: Information and images for Session and Startup and Xfce Power Manager courtesy this Ubuntu Forums Thread.

share|improve this answer
The first didn't work, because it said the file didn't exist and I had to create is using the --create option, but the second option (GUI) did work! Thanks so much! –  Martinio Feb 21 '13 at 15:22
I followed the GUI part and it worked. Thanks. –  Mukesh Chapagain May 10 '13 at 15:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.