Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The left mouse button stops working after 5 or 10 minutes of running Ubuntu 10.10. It is a Logitech MX 1000 wireless USB mouse. Also is there a way to emulate the left mouse click on the keyboard? Mouse pointer move fine, right button works, wheel works.

share|improve this question
    
Here's How to bind mouse buttons to keys. –  Stefano Palazzo Feb 12 '11 at 12:40
add comment

2 Answers 2

I had exactly the same problem. Here's how to solve it. Open a terminal and type:

sudo add-apt-repository ppa:raof/aubergine
sudo apt-get update
sudo apt-get upgrade

...and when the update/upgrade is complete, reboot your system and VOILA! The mouse (including left-click) works.

share|improve this answer
add comment

I had this problem. In the end, I tried another mouse, and it worked - decided it was a hardware issue... mice do break!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.