Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After fixing what appears to be a universal bug concerning wireless on an ASUS U56E notebook running Ubuntu 12.04, my wired connection has stopped working. The fix I found was:

How do I get Wireless working on an Asus notebook U56E

When the wireless works, the wired does not. When I remove the command from the file that makes the fix permanent and restart, the wireless no longer works and the wired works again.

Still new to Linux, so I may be overlooking something, but does anyone have any thoughts on this problem?

Wireless and wired hardware info:

02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N + WiMAX 6150 [8086:0885] (rev 67)
04:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)

The conf file is named: /etc/modprobe.d/iwlagn.conf and the content is

options iwlwifi bt_coex_active=0
share|improve this question
    
Please edit your question to add details about your wireless and wired cards from this terminal command: lspci -nn | grep -e 0200 -e 0280. The pipe symbol is on the right side of my US keyboard on the same key with \. –  chili555 Feb 21 '13 at 13:54
    
Added detail. Thanks chili555! –  Peter Feb 22 '13 at 1:05
    
Which sequence do you have in the conf file? bt_coex_active or 11n_disable or both? Have you tried first one and then the other and then both? Is or are the parameters in iwlwifi.conf? –  chili555 Feb 22 '13 at 1:50
    
The conf file is named: [gksu gedit /etc/modprobe.d/iwlagn.conf] and the content is [options iwlwifi bt_coex_active=0]. Does this answer your question? There is only this one command in the sequence. –  Peter Feb 22 '13 at 3:21
    
Please delete the file: sudo rm /etc/modprobe.d/iwlagn.conf and write a new one: gksu gedit /etc/modprobe.d/iwlwifi.conf. Add a single line: options iwlwifi 11n_disable=1 Reboot and let us have your report. –  chili555 Feb 22 '13 at 3:37
show 12 more comments

1 Answer

Please delete the file:

sudo rm /etc/modprobe.d/iwlagn.conf 

and write a new one:

gksu gedit /etc/modprobe.d/iwlwifi.conf

Add a single line:

options iwlwifi 11n_disable=1 

Reboot and let us have your report.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.