Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug in my 32GB iPod Touch 4G, it mounts a 1GB drive. Rhythmbox does not react, neither does Banshee.

Any ideas how to copy my music?

The output of df with ipod plugged is:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda1             28834716   4347480  23022512  16% /
udev                   1026788       288   1026500   1% /dev
none                   1026788      1496   1025292   1% /dev/shm
none                   1026788       204   1026584   1% /var/run
none                   1026788         0   1026788   0% /var/lock
none                   1026788         0   1026788   0% /lib/init/rw
/dev/sda6             96124904  62709456  28532496  69% /home

and for sudo fdisk -l also with ipod plugged:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0009b4b0

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3647    29294496   83  Linux
/dev/sda2            3648       15927    98639100    5  Extended
/dev/sda5            3648        3769      979933+  82  Linux swap / Solaris
/dev/sda6            3770       15927    97659103+  83  Linux
share|improve this question
    
What gen ipod do you have? Which Ubuntu? With the ipod plugged in, what is the output of df? of sudo fdisk -l? –  djeikyb Feb 12 '11 at 2:20
    
Has it previoulsy worked or is this the first time you've tried to connect it? You can install gtkpod from the software centre which will enable you to load content to the ipod independant of Rhythmbox or Banshee –  Mark Rooney Feb 12 '11 at 2:27
    
@djeikyb I updated, but what fdisk -1 will do? –  Tom Brito Feb 12 '11 at 2:30
    
@Mark Rooney No, it never worked. I activate it on the Apple store. I'll try gtkpod and I post here the result.. –  Tom Brito Feb 12 '11 at 2:31
    
@Mark Rooney gtkpod also doesn't recognize it.. –  Tom Brito Feb 12 '11 at 2:44
show 2 more comments

3 Answers

up vote 1 down vote accepted

It appears there are issues with the iOS firmware on the iPod Touch 4G and Ubuntu - there is a long and detailed post on Ubuntu Forums here detailing methods to troubleshoot and fix.

share|improve this answer
    
The solution uses jailbreak, is there a solution without jailbreak? –  Tom Brito Feb 12 '11 at 12:49
    
Looks like there's no way, so I'll install Windows in dual boot.. –  Tom Brito Feb 12 '11 at 16:15
2  
Ubuntu 11.04 alpha does the trick :D –  Tom Brito Feb 13 '11 at 22:25
    
Oh, no, it doesn't. It recognize the ipod, but the musics will not appear in the ipod player after sync with Banshee (gtkpod doesn't recognize it well). There are issues with the 4G. I'll use dual boot. –  Tom Brito Feb 14 '11 at 11:39
    
@Tom: For me on iPod touch 2G on 11.04, works like a charm. (Not jailbroken). I'm on iOS 4.2.1. –  jrg Feb 14 '11 at 12:31
add comment

Open a terminal. Enter these commands:

sudo add-apt-repository ppa:pmcenery/ppa
sudo apt-get update
sudo apt-get dist-upgrade

and reboot. Your iOS device should work now. Mine did.

share|improve this answer
    
Nothing changed. The device is still mounted as 1GB, and it's not recognized by Rhytmbox, Banshee or gtkpod. –  Tom Brito Feb 12 '11 at 13:58
    
What iOS version are you using? 4.2.1 or 4.1? –  Jonathan Feb 13 '11 at 15:29
1  
Ahh. You're using 9.10. Open up a terminal and type in "sudo apt-get install libimobiledevice0" (without the quotes) and now it should work. Hopefully. –  Jonathan Feb 14 '11 at 20:33
add comment

On Ubuntu 9.10 you'll need to install a package or two from the Package Manager to enable iPod support. Open it up via System -> Administration -> Synaptic Package Manager and type in the following for your search parameters.

libimobiledevice

Check them and install, restart your machine! After that you should be able to sync and load your iPod without any issues :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.