Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use laptop-mode-tools for power management on my laptop and for the life of my I cannot find where to configure the CPU frequency limits. When I'm on battery it sets the maximum limit, regardless of governor or my manual intervention, to 1Ghz. Normally this is good but there are some situations where I want the full 2.4Ghz out of my CPU. However, if I set this manually through the Unity applet or via cpufreq-selector to higher than 1Ghz it is completely ignored while on battery.

This is extremely annoying. I've grep'ed everything in /etc looking for configuration options. The only thing I've found is in /etc/laptop-mode/laptop-mode.conf where the limits are simply fastest, slowest etc. I've found references to several other files, none of which exist, I guess because cpufreqd is not installed. I tried installing that package but the daemon immediately crashed so I guess there's a conflict between that and the laptopmode tools manager. Any ideas?

share|improve this question
add comment

2 Answers

If I understand you correctly, you are trying to configure LMT so that it can run at max speed or ondemand even on battery, right?

If so, please look for power.d folder within laptop-mode directory for individual modules. When you open cpufreq.conf, look for CONTROL_CPU_FREQUENCY="auto" and set it to 1 to activate that module. Then scroll down for further configuration.

I'm on 12.04 LTS so let's hope it is not too different. I'm pretty new to Linux myself so don't be offended if my answer didn't help.

UPDATE: I don't have any "pointer to documentation", sorry. I found out a quick and painless technique to achieve your objective.

  1. Turn off by editing the file /etc/laptop-mode/conf.d/cpufreq.conf (I removed mine).
  2. Look for and set CONTROL_CPU_FREQUENCY="0".
  3. Use Ubuntu Software Center, type in search box "indicatorfrequency". There you will see indicator-cpufreq. Go ahead and install it.
  4. Now, open a Terminal and type indicator-cpufreq to run it for the first time.
  5. Restart the PC.
  6. Voila! You should be able to selectively pick a desired speed or a governor - conservative, ondemand, powersave or performance.
share|improve this answer
    
Thanks I'll give this a try. Do you have a pointer to documentation for this? –  Andrew Myers Apr 3 '13 at 22:22
add comment

Eliah Kagan, you made a typo while editing my Answer. On Ubuntu Software Center for 12.04 LTS, "indicator frequency" must be typed exactly in that order for indicator-cpufreq to show up. Please watch out for typo when you are editing. Thanks.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.