Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop (asus UL80J) has Atheros AR9285. the ubuntu is 12.10 -64 bit

the problem is my wirless adopter work good with all AP that I have except one

I tried:

dmesg |grep wlan

And it gave me the result :

[  901.699027] wlan0: authenticate with 00:1f:a4:f0:22:8f
[  901.713517] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 1/3)
[  901.916719] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 2/3)
[  902.120632] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 3/3)
[  902.324570] wlan0: authentication with 00:1f:a4:f0:22:8f timed out
[  903.441075] wlan0: authenticate with 00:1f:a4:f0:22:8f
[  903.453339] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 1/3)
[  903.656006] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 2/3)
[  903.859921] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 3/3)
[  904.063817] wlan0: authentication with 00:1f:a4:f0:22:8f timed out
[  905.168388] wlan0: authenticate with 00:1f:a4:f0:22:8f
[  905.180769] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 1/3)
[  905.383260] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 2/3)
[  905.587188] wlan0: direct probe to 00:1f:a4:f0:22:8f (try 3/3)
[  905.791117] wlan0: authentication with 00:1f:a4:f0:22:8f timed out

As it's obvious the problem is in authentication process. The access point that i want to connect is WEP

This is the result of

sudo lshw -C network

 *-network               
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 1c:4b:d6:fb:fa:36
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.5.0-23-generic firmware=N/A ip=192.168.1.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:d4c00000-d4c0ffff

Also

sudo rfkill list

0: asus-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no
1: asus-wimax: WiMAX
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I also tried to add the following line as it was famous solution out there, but I just mention the file ath9k.conf didnt exist before running this command:

/etc/modprobe.d > cat ath9k.conf options ath9k nohwcrypt=1

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.