Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Ubuntu 12.04 a couple of weeks ago on my HP laptop (completely replaced Windows). Everything seemed fine until a few days ago when I was unable to connect to the internet with my wireless network at home. I also tried three other wireless networks and also tried to connect by ethernet cable. These are all networks that I have been able to connect to in the past with no problems. In each case it says that I am connected to the network, but when I open Firefox I get the message "Firefox can't find server at start.ubuntu.com". I also tried Google Chrome and that didn't work either.

However, there is one network that I can connect to; the secure network at my school. The first time I noticed this problem was after I installed some updates at school and then went home and couldn't connect. I'm not sure if it had anything to do with these updates or if that's just a coincidence. When I came back to school it was fine and then it stopped working again went I went home.

Here's what I get for the following commands that phipsalabim suggested:

~$ lspci -v | grep -iA 7 network
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at d2500000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

~$ iwconfig
 lo        no wireless extensions.

 wlan0     IEEE 802.11bgn  ESSID:"My School Secure"  
           Mode:Managed  Frequency:2.437 GHz  Access Point: DC:7B:94:87:AE:E1   
           Bit Rate=65 Mb/s   Tx-Power=14 dBm   
           Retry  long limit:7   RTS thr:off   Fragment thr:off
           Power Management:off
           Link Quality=52/70  Signal level=-58 dBm  
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:3300  Invalid misc:570   Missed beacon:0

 eth0      no wireless extensions.

Note that I'm at my school where I do have access.

~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no  

~$ lsmod
Module                  Size  Used by
snd_hda_codec_hdmi     32474  1 
snd_hda_codec_idt      70795  1 
bnep                   18281  2 
rfcomm                 47604  0 
bluetooth             180153  10 bnep,rfcomm
parport_pc             32866  0 
ppdev                  17113  0 
binfmt_misc            17540  1 
snd_hda_intel          33773  5 
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              17764  1 snd_hda_codec
snd_pcm                97275  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
i915                  477611  3 
drm_kms_helper         46978  1 i915
snd_seq_midi           13324  0 
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
arc4                   12529  2 
drm                   241971  4 i915,drm_kms_helper
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
uvcvideo               72627  0 
videodev               98259  1 uvcvideo
snd_timer              29990  2 snd_pcm,snd_seq
hp_wmi                 18092  0 
joydev                 17693  0 
sparse_keymap          13890  1 hp_wmi
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
v4l2_compat_ioctl32    17128  1 videodev
hp_accel               25976  0 
psmouse                97485  0 
wmi                    19256  1 hp_wmi
lis3lv02d              19876  1 hp_accel
i2c_algo_bit           13423  1 i915
video                  19651  1 i915
iwlwifi               401140  0 
mac_hid                13253  0 
wacom                  53300  0 
serio_raw              13211  0 
input_polldev          13896  1 lis3lv02d
lp                     17799  0 
mac80211              506862  1 iwlwifi
snd                    79041  19 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_ra    wmidi,snd_seq,snd_timer,snd_seq_device
cfg80211              205774  2 iwlwifi,mac80211
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
parport                46562  3 parport_pc,ppdev,lp
hid_logitech_dj        18730  0 
ums_realtek            18248  0 
usbhid                 47238  1 hid_logitech_dj
hid                    99636  2 hid_logitech_dj,usbhid
r8169                  62154  0 
usb_storage            49198  1 ums_realtek

And for the wired connection.

~$ lspci -v | grep -iA 10 ethernet
   01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
   Subsystem: Hewlett-Packard Company Device 3662
   Flags: bus master, fast devsel, latency 0, IRQ 43
   I/O ports at 2000 [size=256]
   Memory at d0410000 (64-bit, prefetchable) [size=4K]
   Memory at d0400000 (64-bit, prefetchable) [size=64K]
   Expansion ROM at d0420000 [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: r8169
   Kernel modules: r8169
share|improve this question
    
Yes it sounds stupid, but turn your router off and on again. If nothing changes please open the terminal and run: sudo service network-manager restart. If that doesn't help please edit your question and post the output of the following commands: lspci -v | grep -iA 7 network, iwconfig, rfkill list all, lsmod. We should look at those anyway since you can't connect to other networks either. –  phipsalabim Feb 20 '13 at 22:06
    
my first guess is that it's an N speed problem –  phipsalabim Feb 20 '13 at 22:12
    
@phipsalabim I did turn my router off when this first happened a few days ago. I'm not at home right now. Should I still try your other suggestions now? Once I go home I have no other way of getting on the internet. –  COM Feb 20 '13 at 22:16
    
forget network-manager restart. post the other ones. –  phipsalabim Feb 20 '13 at 22:18
    
edit your question, and post the output there. It's a little cumbersome in the comments, and difficult for others to see. –  phipsalabim Feb 20 '13 at 22:22

1 Answer 1

Ok, everything looks fine. I am pretty sure this is a N-speed issue.

When you get home. Open the terminal and run:

sudo ifconfig wlan0 down

this turns off your wifi. Then run

sudo rmmod -f iwlwifi

this removes the module

sudo modprobe iwlwifi 11n_disable=1

this reloads the module with an additional option

sudo ifconfig wlan0 up

this puts the wifi interface back up.

When you're done, connect to wifi and check if web pages are rendered

These changes only apply to the current session. If this fixes the issue you will have to make them permanent.

In the terminal run:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

in the opened file (iwlwifi.conf) add this line

options iwlwifi 11n_disable=1

If that doesn't fix the issue, report back. I will bow my head in shame, and I'm sure someone more knowledgeable than me will figure out your problem.

good luck


Ethernet issue

12.04 is not compatible with your ethernet card. To fix this.

Download the driver from this page (scroll down to the linux/unix section and download the linux driver from the closest mirror) to your ~/Download folder

then in the term run:

gksudo gedit  /etc/modprobe.d/blacklist.conf

at the end of the file append:

blacklist r8169

save and close file, finally run:

sudo update-initramfs -u && cd ~/Downloads && tar xvf r8101-1.023.00.tar.bz2 && cd r8101-1.023.00 && sudo sh autorun.sh

reboot

share|improve this answer
    
I couldn't find iwlwifi.conf in /etc/modprobe.d/. Is it supposed to be there? I also did a search for it and didn't find it. –  COM Feb 20 '13 at 23:31
    
you can just create an empty one. In the terminal run sudo touch /etc/modprobe.d/iwlwifi.conf then gksudo gedit /etc/modprobe.d/iwlwifi.conf and add the line. Did this fix your issue? –  phipsalabim Feb 20 '13 at 23:36
    
I'm not home yet, so I haven't tried. I just wanted to look at the file out of curiosity. –  COM Feb 20 '13 at 23:39
    
The thing that worries me is that ethernet is not working either. Do you have ethernet access at school? Please post the output of lspci -v | grep -iA 10 ethernet. –  phipsalabim Feb 20 '13 at 23:44
    
OK, I did that. –  COM Feb 21 '13 at 0:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.