Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP DM3 Wifi. I am unable to turn on the Wifi. It says "Wireless is disabled by hardware switch". I have pressed the hardware switch many times, but it's not turning on. Its red. I bought a new USB by Netis which works fine on Windows, but am unable to get it working on Ubuntu. I have tried the following command:

rfkill list all

In my networks, it shows both cards but says it is disabled by hardware switch. Is there any way to forcefully enable it ?

Following are the models:

  1. HP DM3 1039M

  2. Netis WF-2110 Wireless-N Mini USB Adapter

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Try rfkill unblock all, the other command you've tried only lists devices, but doesn't unblock them.

share|improve this answer
    
worked like a charm –  Pankrates Mar 4 '13 at 9:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.