Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried installing b43, STA, wl, ndiswrapper, none have worked, so now I'm trying brcmsmac

Problem is, I have this problem when trying to modprobe ANY module:

WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.

FATAL: Error inserting brcmsmac (/lib/modules/3.2.0-38-generic/kernel/drivers/net/wireless/brcm80211/brcmsmac/brcmsmac.ko): Invalid argument

Apparently I have bcma and ssb running each time I boot, from lsmod: http://pastebin.com/vBwMmuYB

iwconfig gives:

robawalsh@Dell-Inspiron-N5110:~$ iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

And here is the output of lspci: http://pastebin.com/eLHXwYaC

I have run sudo apt-get update && sudo apt-get upgrade

Under Network Settings, Wireless isn't even an option.

share|improve this question
add comment

1 Answer 1

I wonder if you have backports installed. Please do:

sudo apt-get remove --purge linux-backports-modules-cw*
sudo apt-get remove --purge ndiswrapper*
sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo rm /etc/modprobe.d/blacklist

Reboot and give us your report.

share|improve this answer
    
No luck. backports wasn't installed –  robawalsh Feb 20 '13 at 21:04
    
And how about the following commands? –  chili555 Feb 20 '13 at 21:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.