Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have searched about this problem but none of the solutions have worked so far.

I have a HP Pavilion dm4 that initially came with Windows 7. I upgraded to Windows 8 and then replaced that with Ubuntu 12.10. The wifi worked fine until I installed the software upgrades right after installing the os. There is a hardware switch for wifi and bluetooth and it is on.

rfkill list all results 2: hp-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 3: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: no 4: hci0: Bluetooth Soft blocked: no Hard blocked: no

In the Network settings, I only see Wired and Network Proxy, no wireless. I am currently connected to a wired network to resolve this issue. Any help would be greatly appreciated. Thanks!

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

By typing the command :

lspci

You can check what kind of wireless card your HP pavillon have. I guess it's probably something like bcm43xx.

If so, the answer to get your wifi working is :

sudo apt-get install linux linux-headers-generic kernel-package
sudo apt-get purge b43-fwcutter firmware-b43-installer firmware-b43-lpphy-installer firmware-b43legacy-installer bcmwl*
sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer bcmwl*

Reboot !

From this post on askubuntu.com

share|improve this answer
    
This worked perfectly! Thank You! –  R K Feb 21 '13 at 23:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.