Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu in a virtual machine via VirtualBox. I have the seamless mode turned on, which is pretty cool. However, if I move an Ubuntu window around quickly, I can see the redraw of the ubuntu background quickly before it's hidden by VirtualBox again. This isn't a huge deal, but I'd like to fix it, if possible.

I see two possible options that don't involve changing VirtualBox code:

  1. Make the Ubuntu desktop transparent
  2. Make the Ubuntu desktop hidden entirely

Is it possible to do either?

I know that Compiz Fusion has/had a feature to do this for their cube effects, but I don't think that I can run this on the VM. And, even if I could, I don't want to run those services for this one small feature.

My host OS is Windows Server 2008 R2.

share|improve this question

3 Answers 3

Use the same wallpaper in the VM and in the Host?

share|improve this answer
    
I'm doing that now, but it still draws a flicker behind the Ubuntu window. –  EndangeredMassa Feb 11 '11 at 23:35
    
I think its just something that happens when you run a VM. If you were to make the background transparent, it would possibly show up as black. –  Jonathan Mar 22 '11 at 23:49
    
I thought that might help. I asked in the original question if anyone knew how to do that. –  EndangeredMassa Mar 23 '11 at 0:25

What you could also do is to run gconf-editor, to go to /apps/nautilus/preferences and to uncheck the show desktop entry, then, your wallpaper should disappear. P.S. note that you will loose right click on the desktop and desktop icons.

share|improve this answer

Turn off having Gnome to draw the background. Install gconf-editor if you do not have it, run gconf-editor, go to /desktop/gnome/background and uncheck the draw_background value. Not only does it fix the problem, it also is much more responsive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.