Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed it already. but when I run steam it shows:

You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1

Fatal Error:Failed to load steamui.so

My Ubuntu version is 10.04 LTS.

share|improve this question
3  
Do you have your proprietary drivers installed? P.S. Steam supports 12.04LTS and up. –  RolandiXor Feb 20 '13 at 16:41
1  
Exactly. Steam supports 12.04 and newer versions of Ubuntu. Also Ubuntu 10.04 will reach EOL in 1-2 months. (April). Consider to upgrade (or fresh install) to a newer and supported version such as Ubuntu 12.04.2 LTS. –  NikTh Feb 20 '13 at 16:47
add comment

1 Answer 1

Ubuntu 10.04 is not officially supported by Valve.
Please see this Wiki-page for system requirements Valve Wiki

It is not advised that you run Steam on your version of Ubuntu, however if you want to try it anyways the solution to your problem might be installing 32-bit compatibility libraries.

sudo apt-get install ia32-libs 

You should also make sure you have either ATI or NVIDIA proprietary drivers installed
(depending on your graphics card) or you are using the x-swat repository
if you're on an Intel HD4000 chip.

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

Even if this gets Steam to work prepare to run into errors because of graphics driver incompatibility and other problems.

Please don't file bug reports on any problems occuring while using Steam with Ubuntu 10.04 because as stated by 'NikTh' it'll reach its 'End Of Life' with the release of Ubuntu 13.04 in April this year.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.