Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had my Canon MP280 scanner working but since various updates it is no longer recognised despite following all the "answers" on this site and others. It does not work at all with simple scan, scangearmp or gimp. Nothing recognises it. The printer part still works.

share|improve this question
add comment

1 Answer

Press Ctrl-Alt-t, in the terminal run:

sudo add-apt-repository ppa:michael-gruz/canon-trunk

then

sudo apt-get update

you should get a prompt to install new packages, install them. report back

It would be helpful if you provided us with a list of specific things you tried that didn't work.

share|improve this answer
    
Hi thanks for your time.I have tried to follow these instructions before, but it seems to hit an error. Here is the terminal output: –  user133904 Feb 23 '13 at 13:46
    
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: deb.opera.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E585066A30C18A2B W: Failed to fetch deb.opera.com/opera/dists/stable/Release W: Some index files failed to download. They have been ignored, or old ones used instead. –  user133904 Feb 23 '13 at 13:48
    
The above did not seem to work but Ijust noticed that the update manager had some scan updates. After installing them the scanner can be found and workd again with scangear! –  user133904 Feb 23 '13 at 14:28
    
open synaptic package manager. Go to Settings > Repositories. open the Other software tab and remove the ppa you added through the command line. Otherwise it will keep messing with your updates. Glad it's working. Whenever you run into an issue, always run an update first. –  phipsalabim Feb 23 '13 at 14:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.