Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.04, latest updates. when I use gksu in the menu to start a application the prompt for password doesn't appear and the application starts with user priviledges. If I use gksu from commmand line everything works just fine.

I need to create a shortcut: enter image description here

Any idea?

share|improve this question
1  
Your question is not clear to me... be specific please –  Naveen Feb 20 '13 at 14:22
    
Hi, I just need to run applications in graphical mode, using the "gksu application" in the menu to create a shortcut. This used to work just fine with 10.04 and with 12.04 in the beggining, but after some time it no longer asks for the password and runs as user and not as sudo. –  rcordeiro Feb 20 '13 at 15:36

2 Answers 2

up vote 4 down vote accepted

Press Alt + F2 then write : gksu-properties and open it.

The first option should be "sudo"

Authentication mode: sudo

and change the second option from "enable" to "force enable".

Grab mode : force enable

enter image description here

Then retry to open an application with gksu

You can also try the gksudo instead of gksu

Maybe gksudo works better.

Also you can try to create a new launcher

Open a terminal and issue the following commands

sudo apt-get install --no-install-recommends gnome-panel
gnome-desktop-item-edit ~/.local/share/applications/ --create-new

At the opened window complete the appropriate sections

enter image description here

Name: wireshark-root

Command: gksudo wireshark

Comment: anything you want

Find the new launcher and try to open it.

Alternatively you can try to replace the Command: gksudo wireshark

with Command: gksudo wireshark &

maybe the ampersand & helps here.

share|improve this answer
    
Hi, When I try to do "gksu properties" it asks for the password but nothing appears... –  rcordeiro Feb 20 '13 at 15:02
    
Hi, It's gksu-properties, with a dash in the middle. I'm able to run the command and change the option but the result is the same... –  rcordeiro Feb 20 '13 at 15:14
    
Yes , I've corrected my answer. Is gksu-properties. This is run on my machine (Ubuntu 12.04) fine. I don't know why not running in yours. You can also try to use promt. Of course the alternative is gksudo instead of gksu –  NikTh Feb 20 '13 at 16:38
    
gksudo doesn't work also... the strange thing is that it works if I run the command from command line "gksu wireshark" or "gksudo wireshark", but from the main menu, creating a shortcut doesn't work. what do you mean with "prompt"? –  rcordeiro Feb 20 '13 at 16:51
    
With prompt I meant the other option in gksu-properties , but I think it not matters. Do you want to tell us what shortcut you want to create and How you attempt to create this shortcut ? What desktop environment you use , Unity ? –  NikTh Feb 20 '13 at 17:20

Just a guess, because I don't really understand what you want to do, but maybe you have to use /usr/bin/gksu in a custom starter instead of gksu Please be more specific about your problem and tell us, what you want to do exactly.

share|improve this answer
    
I need to open applications with su priviledges. Graphical applications. –  rcordeiro Feb 20 '13 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.