Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install the printer onto my ubuntu system and after having installed the driver, it simply wont install. It shows me the actual printer, but I click print and nothing happens. Everything is filled out in the printer properties, but the "location" field. Is that where the printer's IP address goes?

share|improve this question
try entering your hostname into the location – phipsalabim Feb 20 '13 at 13:43
hostname or IP address of the printer? – Elysium Feb 20 '13 at 13:47
hostname of your machine. check your terminal prompt: for example I'm phips@archimedes. My machines hostname is archimedes. In both my printer configs (one of them is a network printer) my hostname appears in the location field. It's just a guess. – phipsalabim Feb 20 '13 at 13:53
One option is to configure your printer through the CUPS interface. Open your web browser and enter localhost:631 in the address bar. Add and configure your printer. – phipsalabim Feb 20 '13 at 14:00
With my netwrok printer I have put location as "Basement" where the printer is located to differentiate it from the one in the kitchen, one in the study, one in the bedroom etc. (No I don't have so many printers, but if I did, I would put locations.) Keeping it blank should work too. – user68186 Feb 20 '13 at 14:36

No, the location is where the Printer is. Maybe Office or something. Sounds like a driver issue in your case.

Please let us know more about your setup.

Which printer is it? Do you installed the driver automatically or manually? Can you post a screenshot of your configuration?

share|improve this answer
Thanks for the reply. I installed it automatically. It is an Olivetti d-copia 200Mf printer. My boss keeps talking about the IP too.....I think I used the IP to find it and then I let the OS find the driver automatically. – Elysium Feb 20 '13 at 13:41

Is it network or locally connected printer? What protocol did you use and which driver?

You could try to change your driver into Generic PCL 6/PCL XL Printer Foomatic/pxlmono . Under printer setting set to A4, and choose Upper tray as paper source, apply and try to print a test page.

But to give you a better answer I definitely need more info about your printer.

P.S. The "location" field is not required at all, it's just for easier identification of your printer (people usually use "Name" field for that; example: "Xerox_ITsector")

share|improve this answer

Your problem is for sure not in location field being unfilled. It exist there solely for large scattered installation with many printers, so both users and support personnel has additional information about physical location. In other words, location is just text label to make user clear where actual physical printer had been installed.

CUPS printing system, drivers you were about to install and actual hardware create enough points of possible problems. You have to test them one by one from bottom to top.

From personal experience, drivers can be of low quality and making whole process of serious exercise in deep learning CUPS system and finding out what went wrong during installation and/or configuration. Moreover, be prepared to possible problems on every next system upgrade. My Canon LBP-7018C is particular example - Canon's CAPT drivers for .deb-based systems made without compliance to Debian/Ubuntu process.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.