Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
uname -a: Linux ubuntu 3.5.0-23-generic #35-Ubuntu SMP Thu Jan 24 13:05:29 UTC 2013 i686 i686 i686 GNU/Linux

root@ubuntu:/home/ubuntu# apt-get source binutils
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Ignore unavailable target release 'stable' of package 'binutils'
E: Unable to find a source package for 

I did apt-get update before typing the command. How can I get binutils? I am using Ubuntu 12.10.

I am following the instruction on https://wiki.ubuntu.com/Toolchain/Crosscompilers/ARMEABIToolchain

I am stuck at the first line.

I did sudo add-apt-repository ppa:germia/archive3 previously, however I got some errors then, I did sudo add-apt-repository --remove ppa:germia/archive3 to undo the setting. I wonder if my problem is related wtih this PPA?

share|improve this question
    
Are you trying to compile from source? The source package is actually named binutils-source - GNU assembler, linker and binary utilities (source) you can run apt-cache search binutils to find the package. –  Terry Wang Feb 20 '13 at 10:45
    
If you just want to install it however sudo apt-get install binutils. If you want the source you need to enable the source repositories first. –  Warren Hill Feb 20 '13 at 10:55
    
terry wang: yes I am trying to compile from the source file. apt-get install binutils-source outputs E: Ignore unavailable target release 'stable' of package 'binutils-source' –  sven Feb 20 '13 at 11:01
    
I just ran in my home folder (not as root) apt-get source binutils on 12.04. Worked for me. If you are worried the ppa is the culprit, check ls /etc/apt/sources.list.d/germia*. If it's still there, remove it and run sudo apt-get update afterwards. Then try again. –  phipsalabim Feb 20 '13 at 13:07
    
phipsalabim: thank you, I deleted the germia files, but after apt-get update, I get the same error. –  sven Feb 20 '13 at 17:21
show 1 more comment

1 Answer 1

up vote 3 down vote accepted

I would try specifying the target directly.

on quantal (see here)

run as normal user

apt-get source binutils=2.22.90.20120924-0ubuntu2
share|improve this answer
    
I could not vote up because of my rank. thank you, it solved my problem and it is a good method to learn. –  sven Feb 20 '13 at 17:19
    
no problem, glad it worked. don't worry about upvotes they're irrelevant. –  phipsalabim Feb 20 '13 at 17:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.