Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I rebooted the hard way after my system jammed again because FF eats all the ram. (that's a different problem)

I've always gotten away with it, but not this time.

The system came up ok BUT it absolutely refuses to log onto the local house wifi net. I know the net is ok as the Windows box I'm writing this on is on it right now.

I deleted the connection and rentered the password but it will not go on. /var/lib/NetworkManager/NetworkManager.state says everything is turned on.

I know this is my fault but I'd really like to get back on the net. The machine is a Toshiba Satellite.

Any suggestions?

share|improve this question
    
Can't you see wireless networks or connect to a wireless network? It's an important difference. –  Lekensteyn Feb 11 '11 at 22:00
1  
Other than purging and reinstalling the network manager, I don't have an idea for your question. HOWEVER, I WOULD recommend using ALT-SysRq R E I S U B next time you encounter a hang preventing you from shutting down "gracefully". en.wikipedia.org/wiki/Magic_SysRq_key –  bumbling fool Feb 11 '11 at 22:14
    
^ That is amazing. I've always wondered what the system request key was for. –  djeikyb Feb 12 '11 at 4:40
    
Can you open a terminal, run tail -f /var/log/kern.log, then leave that running, try connecting to your network, then post back the results of the terminal? (Note - if you're worried about the Mac addresses showing up, best just blank them out before posting). –  Scaine Feb 12 '11 at 21:45

1 Answer 1

Some troubleshooting steps :

Open a terminal and run tail -f /var/log/kern.log, then try connecting to your terminal. On a successful authentication, you should see something like this :

Feb 12 21:45:37 GroovyTosh kernel: [19329.560236] cfg80211: All devices are disconnected, going to restore regulatory settings
Feb 12 21:45:37 GroovyTosh kernel: [19329.560242] cfg80211: Restoring regulatory settings
Feb 12 21:45:37 GroovyTosh kernel: [19329.560245] cfg80211: Calling CRDA to update world regulatory domain
Feb 12 21:45:37 GroovyTosh kernel: [19329.583441] cfg80211: World regulatory domain updated:
Feb 12 21:45:37 GroovyTosh kernel: [19329.583446]     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Feb 12 21:45:37 GroovyTosh kernel: [19329.583449]     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb 12 21:45:37 GroovyTosh kernel: [19329.583452]     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Feb 12 21:45:37 GroovyTosh kernel: [19329.583454]     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Feb 12 21:45:37 GroovyTosh kernel: [19329.583457]     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb 12 21:45:37 GroovyTosh kernel: [19329.583459]     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Feb 12 21:45:38 GroovyTosh kernel: [19330.677366] wlan0: authenticate with <removed MAC> (try 1)
Feb 12 21:45:38 GroovyTosh kernel: [19330.678697] wlan0: authenticated
Feb 12 21:45:38 GroovyTosh kernel: [19330.678727] wlan0: associate with <removed MAC> (try 1)
Feb 12 21:45:38 GroovyTosh kernel: [19330.680336] wlan0: RX AssocResp from <removed MAC> (capab=0x431 status=0 aid=1)
Feb 12 21:45:38 GroovyTosh kernel: [19330.680339] wlan0: associated

So at least you'll see if you're failing to authenticate (check your WEP/WPA key), or associate (a problem with the router, perhaps).

It might also be worth monitoring the syslog directly, in case this is DHCP related, for example. Just use tail -f /var/log/syslog, perhaps in a second terminal (although much of what is written in kern.log is written to syslog to be honest).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.