Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba Satellite C655D-S5209 with Ubuntu 12.04. I am unable to change the screen brightness. Fn+F6 and Fn+F7 move the brightness indicator, but actual brightness does not change.

I have tried several fixes but none have worked so far:

Updated Bios to newest version and updated graphics driver to latest version.

Tried editing grub about 100 times to include several suggested acpi options - none helped

Tried installing acpi and acpitools - didn't work so removed.

Tried installing fnfx and fnfx-client - didn't work so removed.

Tried editing xorg.conf - might have done something wrong with this because it broke my system, and had to use recovery mode.

The screen hurts my eyes. Either need a fix, some window tinting to put on my screen, or to reinstall Windows.

share|improve this question
    
What graphics card + driver does it have? –  RolandiXor Feb 20 '13 at 5:22
    
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6310] –  Dave Feb 20 '13 at 6:09
    
ATI/AMD proprietary FGLRX graphics driver VESA:WRESTLER –  Dave Feb 20 '13 at 6:13
    
Had the same issue. Installing the fglrx driver from ubuntu repo didn't hel either. But downloading and installing the latest AMD drivers from their website fixed the issue for me. –  Sreekumar R Mar 12 '13 at 11:07
    
Try installing display drivers: askubuntu.com/questions/247145/… –  user142877 Mar 24 '13 at 6:30
add comment

2 Answers

Just boot into an older kernel, probably 3.5.0-19, if you have it. It solved the exactly same problem on my satellite L850.

share|improve this answer
add comment

This is a script I used at some time to change my brightness when I needed a temporary fix.

#! /bin/bash echo -n "Select brightness (0.1 - 1): " read -e BRIGHTNESS xrandr --output VGA1 --brightness $BRIGHTNESS echo Brightness has been set to $BRIGHTNESS sleep 0.5

Save it as brightness.sh (remember to make it executable) and run from terminal or assign to key (Keyboard Shortcuts are in System->Preferences).

This could be easily modified to increase and decrease brightness with different keys.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.