Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed both git and git-core using

sudo apt-get install git git-core

still when i try to run some git command on terminal, I get the following error message:

The program 'git' is currently not installed. You can install it by typing:
sudo apt-get install git

I retried and retried over, I get the same error, Also I tried removing and reinstalling git.

How do I get git to work?

share|improve this question
1  
"when i try to run some git command"? Does it only work with some commands? If so, please provide a few examples of what does and does not work. –  InkBlend Feb 19 '13 at 22:56
    
even simply typing git says me that git is not installed, –  shivshnkr Feb 20 '13 at 5:01
    
when i run sudo apt-get install git, i get message: git is already the newest version. git set to manually installed. –  shivshnkr Feb 20 '13 at 5:15
    
Please run oneconf-query | grep git and which git and create a comment with the results. –  InkBlend Feb 20 '13 at 5:25
    
i get output : git git-core git-man git-gui gitk which git didnt return anything –  shivshnkr Feb 20 '13 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.