Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Ubuntu, and the only thing that isn't working is my Nexus. I'm currently using Airdroid but it takes so long to transfer videos.

Can anybody please talk me through how to do this, as I have followed a few guides but I keep getting errors or unusual return messages.

share|improve this question

Have you tried connecting the Nexus 7 to your Ubuntu machine using the USB cable instead? It will be much more reliable.

It works (for me) using Go-mtpfs with a direct usb connection.

To install, run the following commands in the terminal:

sudo add-apt-repository ppa:webupd8team/unstable
sudo apt-get update
sudo apt-get install go-mtpfs

You can also install the Unity launcher for it by running the following command:

sudo apt-get install go-mtpfs-unity

Before you try to mount the device, make sure it is unlocked (you'll know if it is or not if you see the open lock symbol at the bottom of the startup splash screen (underneath the Google logo) - if you don't see the symbol, it isn't unlocked). Then connect your Nexus 7 via USB, and in the terminal type the following command:

go-mtpfs /media/MyAndroid

To unmount:

fusermount -u /media/MyAndroid

This way has always worked for me, anyway. I was looking for the same information myself and I got it from here:

Give us some more info if you are still stuck... Which version of Ubuntu are you running, the vanilla 13.04 that you download from What steps have you done etc etc

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.