Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've somehow managed to disable my wifi a few days ago. Now the laptop doesn't seem to be able to relate anything to wlan0.

[the hardware switch is on, and I don't have a windows to check if it works there.]

Here are outputs of some commands that might help:

For ifconfig

eth0      Link encap:Ethernet  HWaddr 00:1b:24:80:63:03  
          inet addr:10.5.52.146  Bcast:10.5.52.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:24ff:fe80:6303/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:218095 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71280 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:311077218 (311.0 MB)  TX bytes:6798891 (6.7 MB)
          Interrupt:45 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2996 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2996 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:244647 (244.6 KB)  TX bytes:244647 (244.6 KB)

And for sudo ifconfig wlan0

wlan0: error fetching interface information: Device not found

Also for sudo ifup wlan0

Ignoring unknown interface wlan0=wlan0.

And finally, sudo lshw -C network

      *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 01
       serial: 00:1b:24:80:63:03
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=10.5.52.146 latency=0 link=yes     multicast=yes port=MII speed=100Mbit/s
       resources: irq:45 ioport:2000(size=256) memory:f0200000-f0200fff memory:a0800000-    a081ffff
      *-network UNCLAIMED
       description: Network controller
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f0300000-f0300fff

The output of lspci for my network controller is:

04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

So I tried sudo apt-get install linux-backports-modules-* but it's still the same!

share|improve this question
    
Do you get any clues when you load the driver? sudo modprobe iwl3945 If so, please edit your question to add the error message here. –  chili555 Feb 19 '13 at 21:40
    
This is the warning I get "WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release." –  Keivan Feb 19 '13 at 23:18

1 Answer 1

up vote 2 down vote accepted

It seems your device is hard or soft blocked.

I would try rfkill unblock all. If it is not a question of drivers, this should re-enable your wifi.

share|improve this answer
    
Thanks a lot, that worked like a charm. –  Keivan Feb 19 '13 at 23:18
    
Would you mind giving me some more information about what had happened please? –  Keivan Feb 19 '13 at 23:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.